Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
The kit arrived yesterday morning...



...and today she jumped on the dyno for a baseline - 369 RWHP and 389 TQ



...and this far after only about an hour into it...



Going with the NGK IX Iridiums as recommended as well - 2 steps colder.

I'm really happy with the baseline numbers she put out!! Granted all dynos will read something different, I know. But to be "on the high side" of things is what I'm pleased about. Even the tech said these were highest he's seen for similar setups...we have some nice dense weather today which helps....


...will post more when I get more....
 

Attachments

·
Premium Member
Joined
·
53 Posts
So the 1535 actually exists !

I was starting to believe it was only available in the land of unicorns and $1 / gallon gas.

Ordered on 10/15 and when contacting Edelbrock you would think I was calling the CIA and asking for the full '63 Kennedy file.

It has been scheduled to be shipped 10/25.. 3rd week of November..11/29 and the latest contact 12/3. Then I tell them this is a back order, purchased from one of their authorized install shops... Well, then I can't give you any information, only the shop has a right to that shipping data. So I ask the shop to call.. They get a pocket full of promises and a should be loading this week on a trans-con freight line. Estimated delivery time ? = umm, well, err, you see, mmm could be, it's conceivable that, look a pony ! Dial tone.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #3
...and at approximately 4:00PM PST today, I got blown. :no::grinbiginvert:

 

Attachments

·
Registered
Joined
·
214 Posts
That's a very clean look. Let us know how you like it. Did you have it installed at a shop, if so how much did they charge you to do the install? Thanks Larry
 

·
Registered
Challenger R/T
Joined
·
93 Posts
Congrats!! That looks great!!! Wish the instructions manual had a picture of my car install of my buddy Juan's car. lol
 

·
Registered
Joined
·
1,160 Posts
Are your coil pack covers loose? My drives side one is.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #9
Are your coil pack covers loose? My drives side one is.
No, ...make sure your front bracket/gromet is not bent (pic 132 pg.27), it should be strait; that metal seems a little softer than I'd like it to be, and just a little pressure trying to put a misaligned cover on can bend it!

As a matter of fact, my passenger side cover is ridiculously difficult to remove/replace as it's wedged in there.

I guess too much torque popped it out, and it wouldn't go back on.

Looks like the Coolant reservoir bracket is about 1/4 of an inch too long which places the actual reservoir right up against the passenger-side cover and a 1/4" away from the strut tower. I need to put the reservoir right against the inner strut tower wall and away from the cover.
 
1 - 9 of 9 Posts
Top