Dodge Challenger Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
My USB connect isn’t working...any ideas why?

Hi. I hope someone has a solution. I’m only had the 2017 Challenger SRT 392 for about a month and I’ve had a USB flash drive connected to it since day one with all of my music. All of a sudden today, it seems to have stopped working. At 1st it said “USB Error Reconnect” on the screen. I tried to reconnect it in both USB slots and it said the same thing. I even shut the car off for over 2 hrs and it now just says “Connect USB”. I thought that the flash drive was corrupted so I put the one from my wife truck into the car and same thing…won’t play and says “Connect USB”. The original USB flash drive from the car works just fine in my wife’s truck (RAM 1500). Any ideas?

Obviously I will eventually take it to the dealer, but I rather fix it myself….I don’t like anyone touching my cars/trucks.
 

·
Premium Member
Joined
·
2,331 Posts
Try leaving the USB drive in for a while. I have only used my USB port to install the updates to the Uconnect software. The last time it gave me an error too, then after 4 or 5 minutes it starts to download the update.
 

·
Registered
Joined
·
1,237 Posts
I've had issues with mine on occasion too. Sometimes I have to pull and re-plug to get it going again. My Uconnect did an over the air update a few months ago but didn't change how the USB acted.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #5
Well, good news....overnight it fixed itself. When I got in the car today, it just started working as soon as I started the car up. Must had been a software glitch.
 

·
Premium Member
Joined
·
1,642 Posts
Well, good news....overnight it fixed itself. When I got in the car today, it just started working as soon as I started the car up. Must had been a software glitch.
Hi Crazy Pete,

I'm glad to hear this has returned to normal. Should it occur again, let me know as I can get this over to the Uconnect team for additional troubleshooting.

Jasmine
Dodge Social Care Specialist
 

·
Registered
Joined
·
694 Posts
if it doesn't fix itself, mine didn't, do a reboot. hold pass temp for a good 15 seconds, feels longer & system will reboot. that's how i got mine back.
 

·
Registered
2015 SRT 392
Joined
·
2,701 Posts
if it doesn't fix itself, mine didn't, do a reboot. hold pass temp for a good 15 seconds, feels longer & system will reboot. that's how i got mine back.
Do I hold both up and down buttons or just one to do this?

Ours hasn't worked in a while and it would be Great if that did the trick, so that I wouldn't need the dealer to fix it. I've been putting off a visit to the dealer for as long as I could, but if that doesn't work, then it may be my last option.

Thanks in advance. :cheers:
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,847 Posts

·
Registered
Joined
·
1 Posts
My USB connect isn’t working...any ideas why?

Hi. I hope someone has a solution. I’m only had the 2017 Challenger SRT 392 for about a month and I’ve had a USB flash drive connected to it since day one with all of my music. All of a sudden today, it seems to have stopped working. At 1st it said “USB Error Reconnect” on the screen. I tried to reconnect it in both USB slots and it said the same thing. I even shut the car off for over 2 hrs and it now just says “Connect USB”. I thought that the flash drive was corrupted so I put the one from my wife truck into the car and same thing…won’t play and says “Connect USB”. The original USB flash drive from the car works just fine in my wife’s truck (RAM 1500). Any ideas?

Obviously I will eventually take it to the dealer, but I rather fix it myself….I don’t like anyone touching my cars/trucks.
I was having the same issue with my wife's 2019 Charger. We just bought it and can no longer play music on the SD card like we did in her 2014. I bought the smallest physical sized 64 GB thumb drive I could find so it wouldn't bump into anything in the center console (Sandisk Cruzer Force). I formatted it to get rid of any proprietary software on it and loaded up the music just like it was on the SD card, which it turns out was a 16 GB. It gave me the same error message you got. I called Uconnect customer service and as I was talking to her I realized the problem. It won't recognize a flash drive larger than 32 GB, and she confirmed this. I had the same issue when I updated the maps on her 2014 Charger with a 64 GB thumb drive. I had to buy a smaller one then too. We bought a 32 GB, I made sure to format it first, loaded up the music and it works perfectly.

By the way, I tried to do a soft reset first before I realized the problem but despite everything I searched online, no matter what method I tried...I have no idea how to do one. None of the ones posted online work for our radio.
 

·
Registered
Joined
·
73 Posts
I had a similar problem after a week of having my car. Fastest way to fix this is to pull the fuse for the USB ports. Cleared mine up instantly. Worked on my wifes Pacifica when the DVD entertainment stopped working too. That one took awhile to find the right fuse, Challenger was easy.
 
1 - 12 of 12 Posts
Top