Dodge Challenger Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
I just purchased a 2010 P05064816AB RER MyGig OEM Factory Touchscreen DVD/Navigation Radio (Low Speed BUS Version) to replace the UConnect radio without nav that came in my 2010 SRT8 Challenger.

Is the installation going to be complicated? Will it be pretty much plug and play? How and where do I install the Nav antenna?

Will my existing UConnect mirror mic work with it as well or do I need to get a different one?

Any help and ideas would be greatly appreciated. I'd also like to buy a lockpic and cameras, but not sure which one to buy.

Thanks


:)
 

·
Premium Member
Joined
·
3,546 Posts
I'm not sure were the ant goes because mine came with Nav but the rest should plug in. I got my lockpic and camera kit off ebay. There's alot of vendors that have them buy it now that are new in the box. You can buy them from
MYGIG LOCKPICK that makes them but they are expensive compaired to EBAY.
 

·
Registered
Joined
·
909 Posts
I did the same thing. I put the Nav antenna right above the radio unit and under the air vents. I attached it with zip strips. Make sure the metal plate is facing down.

You will have to replace the wire harness from the mirror to the radio. You will also have to disconnect the uconnect module behind and to the right of the glove box. You will have to drop the glove box to get to it.

If you have any questions I'll try to answer them.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #4
Thanks. So the mic I currently have in the mirror is useless with the mygig?

Does the mygig interact with the uconnect at all or that just going to be a useless part now?

I'm sorry for all the questions, but want to make sure I install it right the first time.
 

·
Registered
Joined
·
909 Posts
Your current system does not have uconnect in the radio itself. There is a uconnect module that works with the current radio you have. The mygig has the uconnect included in the unit so you do not need the module or the current wiring harness. You need to buy the wiring harness that will go from the mirror to the back of the mygig. Somewhere I have the correct part number for the harness. I can find it or probably your dealer can get the right one. I know there are two harnesses, each works for different scenarios. You need the one that works with your mirror mic and the mygig.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #6
Great! That's what I was trying to find out. I just want to make sure that my handsfree telephone will still function.

Sounds like it's just a matter of getting a new mic. Is it a hassle putting the new one in? Obviously you've gone through it. *smile*

Do I need to purchase the mic and cable from the dealer or can it be picked up else where. How much is it?

Guess I'll install the lockpic at the same time I do the radio install too. Just to save time.

Appreciate all the information and any other hints or advice you can give me too.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #7
Another quick question. Will all my steering wheel buttons and evic functions continue to work with the new mygig or do I have to get something else to work with those too.

Sorry for all the questions.
 

·
Registered
Joined
·
909 Posts
The only thing you need is the wiring harness from the mirror to the mygig. The mic is built into the mirror. The harness just plugs into the back of the mirror. I did not remove the old harness. I just had to lower the headliner to install the new harness and pushed the old harness out of the way. When you buy the new harness, there are instructions for installation. They aren't the best but once you get your harness and read the instructions, it may be clear for you. If not, let me know. I will try and help.

Yes your evic buttons work perfectly with this set up.
 

·
Registered
Joined
·
99 Posts
RANGER....

I am a little confused....Are you saying you have a MyGig WITHOUT Nav. and bought a RER (MyGig that has NAV) and you have the mirror with the mics built in that came factory with you car??

If so, PM me with a phone number and i will walk you through it......I have added an RER to my Challenger.

Steve
 

·
Registered
Joined
·
2,823 Posts
subscribed
 

·
Registered
Joined
·
90 Posts
I think he had the basic unit. Non-NAV, Non-Hard drive, just the single cd/radio/satellite unit, but he DID have the U-Connect option.
 

·
Registered
Joined
·
2,823 Posts
Why would you need Nav in Hawaii? Let's get this straight. Your SRT came with a touch screen non-Nav, right? I can't remember seeing an SRT with the standard radio. Either way, it must of had the uconnect module with the mic in the mirror connected to that. Like Coke said, it should be behind the glove box. It is easy to remove. You could sell that for under $200 if you want. I believe it connects in front of the gray plug coming from the car. I'm surprised that the mirror mic has a different harness to the radio than to that module. Although, my mic that came with the module was a small clip. I don't know how the mic plugs into the RER.
 

·
Registered
Joined
·
84 Posts
You will need a rer mic kit, here is a link with the part# Dodge 08-10 Mygig Uconnect Wiring Kit, OEM Mopar - eBay (item 400204106518 end time Apr-19-11 21:50:34 PDT)
You will also need a gps antenna GPS ANTENNA FAKRA for Dodge Chrysler Jeep MyGig Radios - eBay (item 360350168541 end time Apr-06-11 09:51:49 PDT). Mount the ant directly on top of the radio, and youll be fine. Behind the glove box is where the current uconnect module is. Pull the glove box down and disconnect it. if you dont your phone will continuously try to connect to it. let me know if you have any questions,
 

·
Registered
Joined
·
88 Posts
Discussion Starter #15
Thanks to everyone for all the info. I got the cable through my dealer and got it installed. Never realized it integrated into the existing cable already attached to the mirror. Was a little concerned at first by the length.

Iron Horse, is there any difference in the GPS antenna you gave the link to and the stock one? One thing I can see is the length of the cable on the one you provided seems longer. So just attaching the GPS antenna to the top of the radio is good?

Got my lockpick (CHR 550) and cameras in today also. They really include everything you could possibly need to do the install. Going to install the mygig this weekend nad take out the old uconnect, because with the new cable it's useless to me.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #16
Got my new mygig and lockpick installed today. Everything works great, except the on and off button doesn't work.

Anyone else have this issue before and a possible fix. I have a feeling if I go to the dealer and have it starscaned, that might fix it, but would rather hope it's something I'm missing.
 

·
Registered
Joined
·
2,823 Posts
If the on / off button doesn't work, how is everything working great? Is it always on? Did you pull the battery cable when you installed? Don't know if that resets the computer. I know after I reconnected by battery and drove it a mile, I had some bells and dash lights come on and then everything went out and I resumed as before.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #18 (Edited)
The only function that doesn't work is being able to turn it on and off with the radio button. The radio turns off when I open the doors and I seldom turn it off anyways, so having it on all the time isn't that big of a deal.

I'm thinking maybe one of the dip switches might have moved when I was putting it behind the radio, so have to check those this weekend. I'm sure it's something I might have overlooked.

CoastalTech recommended that I disconnect the battery for 20 mins and see if that takes care of it.

And to answer your question, Yes I disconnected the battery and removed the fuse for the entire installation.
 

·
Registered
Joined
·
2,823 Posts
You got a used radio? Maybe that is why the guy sold it. But you are right, I have it on 100% of the time, too. The last time I used the on off button, it wouldn't come back on. I thought I was screwed, but after a mile it turned off to the clock. The when I turned it on, it stayed on uconnect and Dodge for more than a minute. I kept driving and all of a sudden, the radio came to life. So far it has been behaving. Good luck on your fix.
 
1 - 19 of 19 Posts
Top