Dodge Challenger Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
OK, I just got back from my test and tune session at Sacramento Raceway. There was not alot of people there so I got a good amount of runs in. Here is my problem. My best time was a 13.6 at 98mph. This is a 09 R/T, with a Techco supercharger,Tuned by Techco when supercharger was installed, corsa exhaust and Hurst shifter. It is only running 5.5 psi boost, but it is dyno'd at 448rwhp and 446 ft lbs of torque. I am running 305/45/R18 M/T Drag Radials and they are nice an sticky. At first I couldn't get the launch right( never raced with drag radials till now, also first time with a stick). I can't seem to figure out what I'm doing wrong? I launched it at about 4,000rpm so it would not bog off the line, got a little wheel hop but nothing too bad. Any advice on what I might doing wrong? I figure I should be in the 12's with this setup, and my MPH says different. Thanks for any tips or advice on what to do.
 

·
Registered
Joined
·
86 Posts
are you easing off of clutch or dumping it off the line? are shifting too early? what gear do you finish in? please dont say 5th.
 

·
Registered
Joined
·
57 Posts
Can you post your timeslip?Do you own a Predator tuner?You can run some datalogs with the tuner to see how the engine is performing.
 

·
Registered
Joined
·
451 Posts
Something is definitely very wrong. My 09 6 speed RT is stock with RSAs and I ran a 13.6 at 103.8 spinning all the way through 1st and 2nd, so a supercharger and drag radials should net much better times unless you are at a very high elevation. We definitely need more info like DA, timeslips, etc,
 

·
Registered
Joined
·
105 Posts
Discussion Starter #5
are you easing off of clutch or dumping it off the line? are shifting too early? what gear do you finish in? please dont say 5th.

I am pretty much just dumping the clutch, Shifting right at redline (5800rpm)
I finish in 4th gear, i go into 4th with about 100 yards left before the traps.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #6
Can you post your timeslip?Do you own a Predator tuner?You can run some datalogs with the tuner to see how the engine is performing.
I will post my timeslip. I do have the predator that came with the car but I am not very familiar with it yet I am still a newbie to the whole new car tuning thing.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #7
I don't have a scanner but here is the timeslip:

Reaction:.380
I1:2.021
I2: 5.712
I3: 8.806
MPH I3: 81.742
I4: 11.438
ET: 13.673
MPH:97.699
 

·
Registered
2009 R/T
Joined
·
1,371 Posts
Something is definitely very wrong. My 09 6 speed RT is stock with RSAs and I ran a 13.6 at 103.8 spinning all the way through 1st and 2nd, so a supercharger and drag radials should net much better times unless you are at a very high elevation. We definitely need more info like DA, timeslips, etc,
I agree. No tuner here and I've run 13.7s at 107-8 MPH on stock Michelin Pilots with only a CAI added. Would like to hear a video of shifting technique also. Going by the 1/8 mile info you were on pace for a low 13 sec. run. Did you drive it thru the finish line? I know newbies who shut it off at 1000' mark thinking that's the end, result...low MPH.
 

·
Premium Member
Joined
·
423 Posts
I usually release around 3k (but I have sport tires, not drags) and my best is 13.3 @ 107.7 (not official time slip). There's a peak power output per gear that you're either hitting too high above it or well below that threshold. If you hit the rev limiter also at any shift, you've well overshot the threshold too. Listen to the engine, it will tell you when to shift as there is a distinct sound difference when it gives up the power curve. When you hear that, be shifting.
 

·
Registered
Joined
·
419 Posts
Do you have a boost gauge? I'd verify that you're seeing 5.5 psi. Data log with the predator and look for ST KNK (short term knock) among other things.
 

·
Registered
Joined
·
485 Posts
I can't give you much advise because I suck too. I have almost the same set up as you, but no drag radials. It's not easy with the Techco and a 6 speed. You're not alone. I wouldn't get discouraged though. I think it's just going to take me a lot of practice to get better. I raised my redline up to 6000 rpm with the predator and it seems to help me get my shifts right. Good luck and I'd like to see some pics of your ride if you have them.
 

·
Registered
Joined
·
485 Posts
Do you have a boost gauge? I'd verify that you're seeing 5.5 psi. Data log with the predator and look for ST KNK (short term knock) among other things.
That's a good point. When I got my Techco they told me I was at 5.5 and it turned out I was really under 5.
 

·
Registered
Joined
·
1,658 Posts
It looks like several things are wrong.

First, if you calculate your horsepower based off your vehicle's approximate weight of 4200Lbs and a trap speed of 98mph, your car seems to be only producing an estimated 268hp to the wheels and/or 291 hp at the flywheel. Even stock, your car should be putting out more than that...

Also, dumping the clutch at initial take-off is NOT racing. "Dumping the clutch" is for burn-outs, heating the tires, and drifting; NOT racing.

Though most of the members on this forum hate to have to do this, but, in order to achieve the best times with a manual car, you're going to have to teach yourself how to properly modulate (or barely slip) the clutch from the line to keep the engine in its power band: this also prevents unneccessary traction loss. (Think automatic transmission, with a lock-up converter on the big-end)

If I were you, I'd take my car somewhere to insure that it's making the power it's supposed to be making. After that, I'd practice my CONTROLLED launches. This should give you what you're looking for.

Ride on!
 

·
Premium Member
09 RT Challenger auto
Joined
·
3,467 Posts
wow, somthings up/wrong. 98mph,,, Your not making NO Steam. You need more mph. You have a/f gauge. ? What timing you at. ? You have stock cats, highflows or deleted ? Are you running one step cooler and pluges and gaped at 28th
What fuel system you using. None, BAP, dual pumps in hat, ? What octane fuel did you use. ? Any st or lt Knk recorded ? Can you log and post it to look at. Seems they really left alot of safe hp on the table when your tune was set up.
FT
 

·
Registered
Joined
·
105 Posts
Discussion Starter #15
Yes I will data log today at the track and report the results. Thank you for the advice
 

·
Registered
Joined
·
105 Posts
Discussion Starter #16
Just a quick update, I contacted Russ who tuned the car in-house when Techco was still in business, and he had me do some data logging, I sent it off to him and he says he will figure out what's wrong with it.
 

·
Registered
Joined
·
72 Posts
Your MPH is way low for the amount of HP you have. Something is off.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #18
Well turns out the bypass valve slipped on the supercharger.
It was essentially making no boost at all. I fixed it so now it feels way faster.
I will go yo hhe track soon and report what happens.
 

·
Registered
Joined
·
145 Posts
Well turns out the bypass valve slipped on the supercharger.
It was essentially making no boost at all. I fixed it so now it feels way faster.
I will go yo hhe track soon and report what happens.
Thats great news, i always check 1/8th to 1/4 mile mph gains and thats what tells you if your getting more power to the ground.

A car this heavy, 20-22 mph gain is about right and the more power you put down the more mph gain your going to get.

The best part of having more is getting more 1/8th mph, keep all your slips and compare from bone stock all the way thru to where your at with your current mods. This way you can see if the car is gaining with more hp...

Are you running methanol with the blower setup?
BW
 
1 - 19 of 19 Posts
Top