Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hey all:

I have this issue: In order for me to accurately adjust my temperature from hot to cold, cold to hot...I need to first bring the hot/cold knob to the cold position and at that point, a reset???? I am able to adjust cold and hot fine in all increments.

However, lets say I left it in the hot position or hotter when I turn on the car, it remains hot even if I go toward the blue....As if it is stuck. But if I turn it full cold/blue and then go to make my adjustments it works fine.

Anyone have a similar issue??? Just a quirk where I need to start on Cold and then adjust it and it works fine, or does anyone know or have a similar problem and solution.

Thanks,
 

·
Premium Member
Joined
·
3,553 Posts
That's not normal. Mine adjust both ways without turning it down. Might not be something you want to rush to the dealership but the next time you take it in for something have it fixed. Might as well get some good out of that warranty.
 

·
Registered
Joined
·
301 Posts
Have you tested it to see if the temperature change is just delayed? I had a car that would take about 15 seconds before you would see any change in either temperature of in blower location. I'd try making your increments without the reset 1st and seeing if there is just a delay.

If it is just delayed, giving that info to the dealer would probably result in a better warranty experience.
 
1 - 3 of 3 Posts
Top