Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Premium Member
Joined
·
845 Posts
Discussion Starter · #1 ·
As the title says, I tried to update the Nav system on my 15 SPS today but am having problems.

I'm a reasonably bright guy and followed the directions step-by-step. There is a series of codes that need to be entered on this website, then authentication sent to your phone and then put codes into your car. The system started to load as expected, gets through 2 of the 3 moduals then very, very close-- like 100% of final module 3 and 95% of the total download, then ....... locks.

I've retried the download several (4 to be exact) times and restarts on "zero" on module 3, load to a point then...quits. I'm thinking i should take a break and try later, but the download will not allow me to return to my "normal" screen on the 8.4 UConnect. I've tried different combinations of jump drive in/out, engine on/off, The screen either goes dark or has a "put jump drive in again" and then starts the down load over again-- it is a OODA loop at this point.

Any idea on how I can get back to "normal" screen and fool with this later?
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,713 Posts
As the title says, I tried to update the Nav system on my 15 SPS today but am having problems.

I'm a reasonably bright guy and followed the directions step-by-step. There is a series of codes that need to be entered on this website, then authentication sent to your phone and then put codes into your car. The system started to load as expected, gets through 2 of the 3 moduals then very, very close-- like 100% of final module 3 and 95% of the total download, then ....... locks.

I've retried the download several (4 to be exact) times and restarts on "zero" on module 3, load to a point then...quits. I'm thinking i should take a break and try later, but the download will not allow me to return to my "normal" screen on the 8.4 UConnect. I've tried different combinations of jump drive in/out, engine on/off, The screen either goes dark or has a "put jump drive in again" and then starts the down load over again-- it is a OODA loop at this point.

Any idea on how I can get back to "normal" screen and fool with this later?
I probably can't help, but the last time I had an update (over 2 years ago I think) it seemed locked up for a long time, it finally cleared and completed. I did it on a drive to work that is 1 hour, I don't remember the details, but 15 minutes or more while appearing locked up seems right.
 

·
Premium Member
Joined
·
845 Posts
Discussion Starter · #3 ·
UPDATE I got it to load correctly.

PRO TIP: Leave the engine running throughout the entire process.

I did some research and called a few buddies. Apparently the download "works better" with the engine running verses pulling from by battery-- which I had been doing. Funny, as I've done the UConnect updates in the past just letting the battery power the upload. Possibly this program requires more juice?

Everything is working fine and seems normal.
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,713 Posts
UPDATE I got it to load correctly.

PRO TIP: Leave the engine running throughout the entire process.

I did some research and called a few buddies. Apparently the download "works better" with the engine running verses pulling from by battery-- which I had been doing. Funny, as I've done the UConnect updates in the past just letting the battery power the upload. Possibly this program requires more juice?

Everything is working fine and seems normal.
Sounds good. I remember when I did the last one, might have been in my 2015 Charger, while updating the radio still worked, but no controls worked, (not even volume if I remember correctly) so pro tip. CHOOSE YOUR AUDIO WISELY before update so you aren't stuck on Radio Disney, or NPR for ½ hour!
 

·
Premium Member
Joined
·
3,022 Posts
This is not related to your problem, but your Uconnect has to have the latest version of software before you can update the NAV maps in your car.
 
1 - 5 of 5 Posts
Top