Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I was driving my 2013 Challenger the other day with the radio on and the sound just cut off. I can turn it (radio) on and off, change the radio station and adjust the volume with both the knobs and the steering wheel, but no sound. If I use the Sirius radio or a cd the sound works perfectly though.
 

·
Registered
Joined
·
2,323 Posts
Sounds to me, like the radio part of it is broken. But I would do this first, take the radio out and make sure all the connections are in their place. If so, your radio went bad if everything else is working.

Sent from my SM-G975U using Tapatalk
 

·
Registered
2014 Shaker Boosted 392 Stroker M6
Joined
·
2,988 Posts
Try taking it off mute. You may have accidentally bumped the button.
 
  • Like
Reactions: ChallyTatum

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
24,034 Posts
If XM and CD work normal, not the amp or muted. I'd say the tuner isn't putting out any signal. If you do a seek for a station (not a preset), does it find and stop on stations? It may just be a switching issue, but it's a bit odd it's just the tuner

A Guy
 

·
Premium Member
Joined
·
1,745 Posts
I was driving my 2013 Challenger the other day with the radio on and the sound just cut off. I can turn it (radio) on and off, change the radio station and adjust the volume with both the knobs and the steering wheel, but no sound. If I use the Sirius radio or a cd the sound works perfectly though.
Hello Buffett97,
We recommend having your dealer address this concern as they are in the best position to assist you. However, if you do go this route and still need additional assistance please reach out to us privately.
Laura
DodgeCares
 

·
Registered
2015 RT 5.7 M6
Joined
·
9,310 Posts
FYI here are some TSBs that may apply.

TSB 08-056-14 (2012-2014 SRTs only) "No Audio From The Radio Caused By The Amplifier Muting Audio"
TSB 08-033-13 (2012-2013 challengers) "Two Or More Speakers Will Mute When Playing Certain Media Sources"
TSB 08-024-14 (2011-2014 challengers) "Radio mute issue in tuner mode "
 

·
Registered
2013 SRT 392
Joined
·
10 Posts
FYI here are some TSBs that may apply.

TSB 08-056-14 (2012-2014 SRTs only) "No Audio From The Radio Caused By The Amplifier Muting Audio"
TSB 08-033-13 (2012-2013 challengers) "Two Or More Speakers Will Mute When Playing Certain Media Sources"
TSB 08-024-14 (2011-2014 challengers) "Radio mute issue in tuner mode "
Wow! That first TSB may solve my issue. Thanks!
 
1 - 8 of 8 Posts
Top