Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 16 of 16 Posts

·
Premium Member
Joined
·
1,456 Posts
Discussion Starter · #1 ·
2016 Scat Pack Shaker, 18K miles, 3 month old battery, only mod is a Tazer I have had installed for 4 years. Coming to work this morning, about a mile from home. Crossed, slowly, a set of train tracks and the entire dash went blank, radio and all. Car didnt die, dash rebooted, but when it did the radio had no volume and the inside temperature display showed 17 degrees on both sides. Once I got back home I restarted the car and all was normal again, but I took the Ram on to work until I could sort this out. My initial thought is that the Tazer is a little loose and it moved a bit when I crossed the tracks, but I just wanted to see if anyone else has had a similar issue,
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,433 Posts
Was the little red battery light lit up after it all came back on?
 

·
Premium Member
Joined
·
1,456 Posts
Discussion Starter · #3 ·
No, there were no warning lights at all.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,433 Posts
I had something similar occur repeatedly in my 2012 Charger, but it was something to do with the charging system and lit up the red battery each time to indicate as much.

Each CAN system stores codes, and the one responsible for the dash stuff is no different. You’ll need some special equipment to read those stored codes though. If all else fails, take it to the dealership and have them pull the relevant codes.
 

·
Premium Member
Joined
·
1,456 Posts
Discussion Starter · #5 ·
I knew of some cars with alternator troubles a few years back and had that thought, but it seemed odd that it happened just as I hit he railroad crossing and there were no warning lights. Ill drive it this weekend and see if the problem reappears. Thanks for the response.
 

·
Premium Member
Joined
·
1,925 Posts
2016 Scat Pack Shaker, 18K miles, 3 month old battery, only mod is a Tazer I have had installed for 4 years. Coming to work this morning, about a mile from home. Crossed, slowly, a set of train tracks and the entire dash went blank, radio and all. Car didnt die, dash rebooted, but when it did the radio had no volume and the inside temperature display showed 17 degrees on both sides. Once I got back home I restarted the car and all was normal again, but I took the Ram on to work until I could sort this out. My initial thought is that the Tazer is a little loose and it moved a bit when I crossed the tracks, but I just wanted to see if anyone else has had a similar issue,
I had something similar occur repeatedly in my 2012 Charger, but it was something to do with the charging system and lit up the red battery each time to indicate as much.

Each CAN system stores codes, and the one responsible for the dash stuff is no different. You’ll need some special equipment to read those stored codes though. If all else fails, take it to the dealership and have them pull the relevant codes.

Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
DodgeCares
 

·
Registered
Joined
·
307 Posts
My 13 Ram has done that off and on for a couple years. It scared the crap out of me the 1st few times. I always forget to tell the Dealer. Taking it in tomorrow for Trans/Trans case fluid change, so hopefully I'll remember.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,715 Posts
Find and check the main ground strap(s)

A Guy
 

·
Premium Member
Joined
·
1,456 Posts
Discussion Starter · #9 ·
I found 2 grounds in the battery area, and 2 beneath the underhood relay box, is there another leading to the engine that I havent found? So far are are clean and tight, the only I have found is that the Tazer was slightly loose, pushed it up maybe 4-5mm.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,433 Posts
I found 2 grounds in the battery area, and 2 beneath the underhood relay box, is there another leading to the engine that I havent found? So far are are clean and tight, the only I have found is that the Tazer was slightly loose, pushed it up maybe 4-5mm.
ground strap from engine to trans,pcm grounds, etc. lots of others but none likely to be culprit. Drive it and see if it recurs, diag further then
 

·
Registered
Joined
·
307 Posts
Find and check the main ground strap(s)

A Guy
Good advice, while getting it serviced Friday, the Dealer found a ground loose from under the dash it seems, I think it noted 10mm nut, that they tightened so we will see.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,715 Posts
Good, I hope that's it (y)

A Guy
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,433 Posts
Good advice, while getting it serviced Friday, the Dealer found a ground loose from under the dash it seems, I think it noted 10mm nut, that they tightened so we will see.
If there were a betting pool set up to take in money and pay out prizes based on what actually caused the initial problem, all my money (~$40) would be on that loose 10mm connection in the dash. It just makes more sense for it to be somewhere in there than anywhere outside the cabin.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,715 Posts
There was this guy once who found this also


A Guy
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,433 Posts
There was this guy once who found this also


A Guy
I actually know that guy...met him once too! And let me tell you, you’re better off not listening to anything he has to say.

The man is widely known as an inveterate liar, and I’m about 75% sure he listens to both country AND rock music when he drives his stupid cars around.

Can you imagine, listening to two different kinds of music?!? The man is clearly unstable, and his threads on this forum absolutely back that up.

Beware, and be aware!

The more you know...

regards,
Gert T.Frobe
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,715 Posts
So it's GTF? I would have sworn it would be WTF...

A Guy
 
1 - 16 of 16 Posts
Top