Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
Well this whole thing started yesterday I was sitting in line at whataburger and I started hearing a bubbling sound and then steam started to come out from under the hood. So I pulled over and found the radiator cap had worked itself loose and was shooting steam out. So I tightened it up and went on my way. I still had coolant in the reservoir so I went to work. I went home for lunch with no issues but on my way back as I pulled into the parking lot I heard a ring and realized my temp had pegged out. I went in to work and grabbed a gallon of coolant from the warehouse for when I got off. When I got off I filled the reservoir to the fill line and went home. When I got there I let it idle for a while to see if anything would happen nothing I revved the motor up to 2500 rpm for a couple minutes and it only warmed up by a little so I thought I was good. I got up this morning and went to warm up my car because it is near 20 degrees outside. When I get in my car I realize my heater is blowing cold bit I was running late so I took off. The temp gauge began to rapidly increase so I pulled into the taco villa parking lot to grab some breakfast and let it cool down. When I left it began to rise again but I was only a couple miles from work so when I pulled into the parking lot again I hear the tone of the temp warning light, so I pulled it into the service drive and told them the situation and handed over the keys. Now I'm sitting here waiting for them to pull it in and tell me what parts are needed to get it fixed.

Sent from my HTC One X+
 

·
Premium Member
Joined
·
2,891 Posts
I would pressure test the cap to make sure there is not an issue, Also you could have gotten air in the system so I would bleed that as well to make sure. If the above does not work then I would pressure test the whole system and also replace the t-stat .
 

·
Registered
Joined
·
154 Posts
Discussion Starter #3
I'll make sure they get that checked thanks

Sent from my HTC One X+
 

·
Premium Member
Joined
·
7,309 Posts

·
Premium Member
Joined
·
4,050 Posts
"the radiator cap had worked itself loose". ? I wonder when the last time someone was under your hood besides you? Unless you turned it, I don't see this just working itself loose.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #6
"the radiator cap had worked itself loose". ? I wonder when the last time someone was under your hood besides you? Unless you turned it, I don't see this just working itself loose.
That's what I'm wondering but it's been awhile since I have touched it and between Thursday and Sunday I put a 1000 miles on it and no one has had a reason to mess with it

Sent from my HTC One X+
 

·
Registered
Joined
·
154 Posts
Discussion Starter #7
Well looks like all it was is the radiator cap failed

Sent from my HTC One X+
 
1 - 7 of 7 Posts
Top