Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
hi, I'm looking for help on an error code on my 2012 srt challenger 392. The car is about a year old and has about 12k miles and is all stock. just this week the engin light came on, with the code P2016. Which is for the intake manifold, run position sensor/switch, bank1 low. my question is where on the engin is the sensor so I can check it and the connector. I have looked and found two posible devices on the back side intake manifold, but I am not sure if one of these is the right sensor. called the dealer to see if i could buy a service manual, just to locate the sensor. but they say the service manual is not avaible for sale for this year yet. i have already fixed an airbag light problem on my own ( i will do anything to fix it myself and not go to the dealer, who does not have a clue) most likley it is a loose connector, i just need to know where. the car runs purfect with the engin light on.

thanks for any help.
 

·
Premium Member
Joined
·
919 Posts
Look in the parts manual attached on 8-605 and 8-606, I think it may be the MAP sensor that's your problem but all of the other engine sensor locations are also shown. I couldn't find one specific for your problem but then I can't find a manual for the 2012 year. Good luck.

http://www.mediafire.com/?z0kcw1tm2y1r3nc
 
1 - 3 of 3 Posts
Top