Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
421 Posts
Discussion Starter #1
I don't know if anyone has had this happen to them before but it is happening to my '13 Challenger SRT and it's driving me insane as I'm clueless as to what the problem can be.
About a month ago, my car was hit in the front left at less than 15mph, the air bags never deployed. The only damage to my car was the front left fender, front bumper the tire and rim. But now after my car sat for over a month at the body shop because they were so busy, everything seems to have gone haywire electronic wise.
I brought my car home Thursday and it was fine. I went for gas, turned it off, restarted it after it wasd filled, came home and it started with no problem. Friday morning when I went to start it to go to work, the car would not start. It just made the clicking sound of a dead battery. So I had the car jumped, I put it on a battery charger all day until after work. I took the car for tires after work and while waiting to have them installed, the alarm wentoff for no reason. I turned it off and then moved the car so the tires could be installed and the air conditioner was on full blast but the dial was in the off poisition. The rear window defogger light was also blinking too. The A/C and rear window defroster bug has happened several times since Friday. I checked the voltage of the battery under a heavy load (headlights on, radio on, interior lights on, both seat heaters, rear window defroster, A/C on full blast, radar detector plugged in, wipers on and steering wheel heater on) and the voltage was between 13.4 and 13.7 with the car running. While I'm driving, the battery is at a steady 13.9-14.1 with just the radio, A/C and radar detector plugged in. With the car off the battery was steady at 12.7. I was thinking that either the computer needs to be reflashed or the PCM is on it's way out. Anyone have any idea's what could be the problem??? :icon_confused:
 

·
Premium Member
Joined
·
1,449 Posts
Have you tried to reset the system by unhooking the battery for 15 minutes?
 

·
Registered
Joined
·
272 Posts
These cars do some really trippy stuff when the battery starts to go out. They are VERY voltage sensitive. I wouldn't think a 2013 would be needing a battery yet, but I bet that's what you have going on.
 

·
Registered
Joined
·
4 Posts
I am super late to this discussion, did you ever figure out what was wrong. I have a 2010 srt8 sounds like similar problems. Mine alternator died first had it changed twice and the battery. But alternator still won’t charge the battery car keeps dying. Dealer said buy a new ecm. I sent ecm to get fixed. They said there’s no problem with it we will update it. Put everything back in now A/C flashes, no air blows, passenger airbag light is on and battery still not charging.
HELP!!!
 

·
Registered
Joined
·
2 Posts
Not sure if you figured it out but i just took mine in (2010 challenger rt) after i replaced the battery and alternator still drained my battery with in 20 min. Come to find out my old alternator had blown out the pcm. Which was causing my battery to die since new alternator wouldnt charge it...im pretty sure its what it is since the symptoms are similar on my car as well
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
18,733 Posts
Welcome to Challengertalk Frank ;)

A Guy
 

·
Registered
Joined
·
2 Posts
Thank you....its been a headache trying to figure out this whole situation with my car but after researching and reading finally figured it out so just thought i share my experience hopefully no one has to go through all the headache i did
 
1 - 9 of 9 Posts
Top