Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I picked up the pedal commander for my manual 6 speed 2017 challenger RT and after owning it for a month I’m pretty satisfied with it. The install was quite easy and mounting the controller is no problem with a few places to put it. It comes with multiple modes the one that I currently found that works best for me is sport (+1) which makes the throttle very responsive but isn’t overkill. I tried sport + (+4) and I could hardly drive my car, ridiculous sensitivity and easily broke loose even with my upgraded tires. As for eco and city I can’t say much considering I hardly used them. The biggest difference however is when you turn it off after a week of having it on, the car literally feels dead when it’s not in sports mode, kind of makes me think of how I ever drove without it. Also I haven’t had any issues with it throwing any codes I come to a full stop, change the setting and wait about 30 seconds just to be safe to avoided any problems that could occur if you change it while driving. Also my exhaust definitely sounds better with it on. Overall is it worth the price tag? If you’re someone like me who just wants to have more fun with their hemi and doesn’t really care to make it a drag car then yes, but if you’re looking purely for speed then invest the money into actual performance modifications.
 

·
Registered
2016 Challenger RT Plus
Joined
·
344 Posts
I’ve had mine for about a week now, I think I’m the only person that’s a little disappointed. It’s a fun little toy, but not worth the $300 price tag. Fortunately I got mine used at a lower price.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
18,605 Posts
Drive with it for a while until you are used to it, then turn it off...from what I've seen, that's when the difference is most obvious

A Guy
 
  • Like
Reactions: Kazy_RT

·
Registered
Joined
·
172 Posts
Had mine for a about a year and the other day it started throwing codes. Not sure what’s happening. It did one then I cleared it by unplugging it and plugging it back in. Then was fine for about a week then it just started doing it about five minutes after I’d plug it in. Did it 5 times in an hour. Really crappy cause I loved it when it worked
 
1 - 5 of 5 Posts
Top