Dodge Challenger Forum banner

41 - 60 of 294 Posts

·
Premium Member
Joined
·
1,949 Posts
1st attempt was a couple weeks back and I got a 4.73 with wheel spin. Today I decided to try again and launched from idle with no wheel spin (feather it for a few feet then nailed it) and got 4.76 0-60mph

This 392 is bad ass and very consistent without even trying hard! I love it!
 

·
Premium Member
Joined
·
1,045 Posts
Discussion Starter #42
My best was a 4.95, since I put on the Arrington 90mm TB, the best I've managed is 5.65sec in my 2010 6.1L 6-speed. ARH and catless mids will be going on next week, will see how that affects my times.

For the record, my 4.95 was this spring when it was 40 degrees outside, it is now in the 90s... big difference.
 

·
Banned
Joined
·
1,428 Posts
5.16 is my best time with my stock 2011 R/T 6 speed. The temp was in the low 70's. No spin in 1st, chirpped into 2nd and 3rd.

 

·
Premium Member
Joined
·
667 Posts
4.4 is my best I had others a bit lower but could not duplicate. I am thinking there was wheel spin.

Question, What are the 392 six speeds doing for 0-60 times?
 

·
Registered
Joined
·
598 Posts
R/T Classic 6 Speed Manual. I've only done 2 0-60 runs. The first time I missed 3rd badly and ran 6.79. The second time, I still missed 3rd but not as bad and ran 6.08.

I haven't attempted any more runs.
 

·
Registered
Joined
·
3,338 Posts
why don't you guys take your cars to the track to see what it will really do. these time are no more accurate than counting 1 mississippi, 2 mississippi. go get some real times.
 

·
Registered
2011 392 SRT, 2010 R/T Classic, 2019 R/T Plus, 2016 SXT Plus
Joined
·
447 Posts
4.34 was my best, followed by 4.44 and 4.54.

I was just messing around. I didn't think these times were all that great so I didn't bother taking pictures.

I don't know about you guys, but the 392 and an auto seems faily easy to hit low-mid 4s. My biggest issue is hooking up and not spinning the tires. I need more meat on the back.

Mods? a catch can and a pair of filter mags.
 

·
Banned
Joined
·
1,428 Posts
why don't you guys take your cars to the track to see what it will really do. these time are no more accurate than counting 1 mississippi, 2 mississippi. go get some real times.
How is taking it to the track going to get me a more accurate 0-60mph time?

I just think people that can't pull off a decent 0-60 blame it on the timers accuracy ;)
 

·
Registered
Joined
·
3,338 Posts
3.2 seconds
 

·
Registered
Joined
·
779 Posts
why don't you guys take your cars to the track to see what it will really do. these time are no more accurate than counting 1 mississippi, 2 mississippi. go get some real times.
Thats what I have been doing....60 passes this year and had the timer on for about 90% of them. Averaging 4.32 sec, thats using the Hoosier 17inch DRs. After that many, I can pretty much tell which are accurate based on the final 1/4 mile ET and MPH
 

·
Banned
Joined
·
162 Posts
I'm not buying that 3.2 seconds , sorry , unless your jet powered. I've hit 3 seconds also but its all spin
 

·
Registered
Joined
·
2,311 Posts
anything stock below 4.5 is BS...everybody knows it. Personally, I don't see anything below 4.6 even possible.(stock) EVIC's stink, fun, but totally inaccurate. I don't understand the mentality of those who question that fact still today.:scratchhead:
 
41 - 60 of 294 Posts
Top