Dodge Challenger Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1 (Edited)
UPDATE:

It looks like they've made the official crom. You can now download u7136-r07 on the main download page.

-----
Just thought I'd let everyone know that there was a U7136 predator update posted over on the diablosport forums which adds the throttle boost parameter. The original thread can be found here. I will say that i did notice a difference with the throttle boost and 93 tune.
 

·
Banned
Joined
·
1,340 Posts
yes, there is a difference in the predator for the V6 Rick, Just that you cannot make all the changes that you can make on the V8.
 

·
Registered
Joined
·
1,246 Posts
Just thought I'd let everyone know that there was a U7136 predator update posted over on the diablosport forums which adds the throttle boost parameter. The original thread can be found here. I will say that i did notice a difference with the throttle boost and 93 tune
What kind of "difference" did you notice? Please expand on that :)
 

·
Registered
Joined
·
232 Posts
I got the more "custom" one, i'm not sure if its the same as the ones in the update, but I assume it is as there doesn't seem to be any problems as they use us as beta tester :p

Anyways there is no longer a dead spot from 0-20%. I would day 1%-10% throttle you feel the go now, and after 10% its like going to 40% before. Its a pretty big change. You should feel it matches more like all the other cars out there, and might use more gas.
 

·
Registered
Joined
·
133 Posts
I just tried this and ended up with a fried PCM.

Looks like I will be at the dealer tomorrow.:fight:

here is my post on diablo's site:

Mike, I have a big problem now. I installed the new u7136_9t07a_468.crom, did the requested cal updates and tried to install the 93 oct tune. Everything went normal until the end. Then I got a "tune failed to write" notice with a reboot. After the reboot the tool asked to reinstall the original tune, but nothing happens. Now the car just makes funny sounds and blinks the light with the ignition on.

Aside from a visit to the dealer tomorrow, what else to do?

The modification from the stock 93 oct tune was bumping up the throttle cal.

car is a 2010 Challenger 3.5L
 

·
Registered
Joined
·
145 Posts
I just tried this and ended up with a fried PCM.

Looks like I will be at the dealer tomorrow.:fight:

here is my post on diablo's site:

Mike, I have a big problem now. I installed the new u7136_9t07a_468.crom, did the requested cal updates and tried to install the 93 oct tune. Everything went normal until the end. Then I got a "tune failed to write" notice with a reboot. After the reboot the tool asked to reinstall the original tune, but nothing happens. Now the car just makes funny sounds and blinks the light with the ignition on.

Aside from a visit to the dealer tomorrow, what else to do?

The modification from the stock 93 oct tune was bumping up the throttle cal.

car is a 2010 Challenger 3.5L

Wow, sorry to here something went wrong with your tune... hopefully the dealer can reflash it without charging you for a new unit. I guess this would be a heads up for other predator owners.
 

·
Registered
Joined
·
1,391 Posts
Like anything computer related, I tend to believe any problems are often user error.

I installed this on my predator, did the update to the calibration. Took a long time to update the car, but after it backed up my original tune and then installed the new tune just fine.

Did you restore your original backup before updating the predator and your car?
 

·
Registered
Joined
·
133 Posts
I returned the car to stock, did the crom update, then the cal update.

I added this to the diablo post:

Mike, I was recalling some other weird things from the tune last night.

Normally I install the 93 tune first, then later do a quick adjust for the tire size and trans firmness. Last night I did the the throttle cal setting first (20%), then proceeded to do the trans and tire size adjustment before writing the 93 tune to the car. After the throttle adjustment the tool showed an asteric by the throttle selection. Okay, I then did the tire size and was asked to turn the key on/off. After the tool went back to the modify screen, all of the selections had an asteric by them. When I checked the throttle cal again, it showed a number (8650) instead of the 20% I first set it for.

Could this be a bug in the crom that resulted in my failed write and dead pcm?

Like anything computer related, I tend to believe any problems are often user error.

I installed this on my predator, did the update to the calibration. Took a long time to update the car, but after it backed up my original tune and then installed the new tune just fine.

Did you restore your original backup before updating the predator and your car?
 

·
Registered
Joined
·
133 Posts
Question, when the car comes back with the new PCM, can I revert the Predator back to the previous crom and use what I had before? The Predator was not able to restore the stock tune after the crash.
 

·
Registered
Joined
·
398 Posts
I returned the car to stock, did the crom update, then the cal update.

I added this to the diablo post:

Mike, I was recalling some other weird things from the tune last night.

Normally I install the 93 tune first, then later do a quick adjust for the tire size and trans firmness. Last night I did the the throttle cal setting first (20%), then proceeded to do the trans and tire size adjustment before writing the 93 tune to the car. After the throttle adjustment the tool showed an asteric by the throttle selection. Okay, I then did the tire size and was asked to turn the key on/off. After the tool went back to the modify screen, all of the selections had an asteric by them. When I checked the throttle cal again, it showed a number (8650) instead of the 20% I first set it for.

Could this be a bug in the crom that resulted in my failed write and dead pcm?

I got the throttle sensitivity adjustment to the last saved tune I uploaded to the Diablosport forum. Worked great no problems. Never noticed any throttle cal setting. My tune was auto upshift disable and 91 oct tune. Mike made the throttle sensitivity adjustment to it. Just don't mention the Diablo to the dealer and you should be OK.
 

·
Registered
Joined
·
1,246 Posts
i bet you'll need another predator since that one is married to your fried PCM.

I was wondering the same thing!!! I personally would be scared to death to try and use that predator on your new PCM.

Ha, as a good bit of information for those dabbling with the Predators, let everyone know what the PCM costs. I'm assuming they are not going to cover that under warranty?
 

·
Registered
2009 Challenger R/T
Joined
·
2,991 Posts
Try sending the predator off to Diablo so that they can unmarry the predator
 

·
Registered
Joined
·
133 Posts
I don't know about the warranty yet. Right now I am doing my best "Forest Gump" impersonation when talking with the service department.

"Stupid is as stupid does!" Right now I am feeling pretty "stupid".:notallthere:

I was wondering the same thing!!! I personally would be scared to death to try and use that predator on your new PCM.

Ha, as a good bit of information for those dabbling with the Predators, let everyone know what the PCM costs. I'm assuming they are not going to cover that under warranty?
 

·
Registered
Joined
·
302 Posts
I don't know about the warranty yet. Right now I am doing my best "Forest Gump" impersonation when talking with the service department.

"Stupid is as stupid does!" Right now I am feeling pretty "stupid".:notallthere:
Heh that made me chuckle.

Though I am sorry for your trouble and am not trying to make light of it.

It's these stories that scare me off from the predator. The 0-20% performance boost is VERY tempting but having my daily driver "temporarily down due to technical difficulties" would be a real pita :werd:.

Edit to add - I would consider 7 weeks completely unacceptable. For one of the big 3 not to be able to replace a part on a new car in less time than that is ridiculous.
 
1 - 20 of 21 Posts
Top