Dodge Challenger Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3,532 Posts
Discussion Starter #1
So i ordered some purple LED dome lites from AAC (advanced automotive concepts) and waited a good month or so for them to come in. I installed one of them to see if I liked them.Well I wasnt sure what to make of them. There are 6 LEDs and 3 are red,3 are blue. I guess thats purple to them.

But i noticed that there are times when it looked like some of the red LEDs are staying lit when the lite is off. I figured it must be a reflection so I dont do anything about it. Well this past weekend, I installed the other LED and notice for sure, some of the red leds stay on when the lite is out.

Got my meter out and noticed this:

With the door open, I have 12v at the socket without any lite installed.

LED installed, I get 12v as well. with the LED in, the red and blue lite up.

Shut the door and the voltage drops after a while but only drops to about 5 v. the red LEDs stay on (actually, one red led in one light and 3 red leds in the other... go figure)

Voltage eventually drops to where all the leds go out.

If the lamp is in there, it drops to 0v and the light goes out. Probably related to the lower current draw of the LED is not draining off the dome lite voltage.

heres the weird thing- the LEDS do not lite up when I use the switch on the lite. Well only the red leds lite up. When I use the lite push button switch, i get 5v at the LED if the car is off. if the car is on, i get both blue and red leds to lite.
'
the dimmer switch turns all 6 LEDS (blue and red) on. turn switch off and the leds go off.

So why doesnt the lite switch work to turn my LEDS on fully when the car isnt running???? Why is the volathge only 5v then.

Door open= lite work.
Dimmer switch= lite works
car on, lite switch on=lites work
car off, lite switch on= lites dont work. only reds

close door, leds REDs stay on for a while.....

bizarre
 

·
Registered
Joined
·
46 Posts
I had the same problem I was using 42mm led white festoon bulbs reordered 44mm wire loop white leds removed the caps from the ends of the stock bulbs put them on the new wire loop led bulbs wire runs through it and it works right..

Also used one of the wire loop bulbs in the trunk without any caps (that one dont need caps)

Now if I can just solve the rear seat is not really a bulb problem I d be ok. Yes the back of my seats is what I m talking about
 

·
Registered
Joined
·
752 Posts
I had the same problem I was using 42mm led white festoon bulbs reordered 44mm wire loop white leds removed the caps from the ends of the stock bulbs put them on the new wire loop led bulbs wire runs through it and it works right..

Also used one of the wire loop bulbs in the trunk without any caps (that one dont need caps)

Now if I can just solve the rear seat is not really a bulb problem I d be ok. Yes the back of my seats is what I m talking about

The seat back lite is infact a LED, so is the door handle switch.
 

·
Registered
Joined
·
3,532 Posts
Discussion Starter #4
my LEDS from AAC already had the caps installed. I ended up taking them out and putting the stock lights back in. if I get adventuraous, i may try them again.

its just odd that no one else is having the same problems im having
 

·
Registered
Joined
·
46 Posts
The seat back lite is infact a LED, so is the door handle switch.

what door handle switch??

if the seatback is an led, but it what is referred to as warm white.. most of what people buy aftermarket is cool white.. I just want them to all match.. I Put my stocks back in too without the heatshields and have had no problems just a brighter interior. If I can ever gedt some bulbs for the seatbacks that are COOL white I will put the cool white led back in the dome/map

again wehat door handle light? Guess SE's dont got that maybe
 

·
Registered
2010 SE
Joined
·
229 Posts
This sounds like my car, but its not really a problem IMO.

I have the full red LED bulbs from AAC, so I can't speak as to why only red is showing up in your's, however I do have some other opinions.

The LEDs only getting slightly bright with the key off (you said only the red light up, the blue might just be too dim to see) I think is a preventative measure from Dodge to keep the battery drain to a minimum when you leave those lights on by accident. There's not really a remedy for that that I can think of :/

The lights stay on for a few minutes then the voltage drops off slowly as to make a "fading" effect (I believe it happens other times too). I like it :dunno:

Hope this helps.
 

·
Premium Member
Joined
·
28 Posts
I have the same issue, thought something was wrong with the LED's I ordered until I spoke with several people who have installed LED's of varying manufacturers and they have basically the same problem. LED's are polarity sensitive, will only work with the positive flowing in one direction, hence the name L.E.D. Light Emitting "Diode". A Diode is a electronic check valve. Without having a wiring diagram in front of us it is hard to understand but I suspect it is due to the way the lights get their grounds (negative). It is not a basic floating ground. Cars are much more complex now. As far as the Map Lights are concerned ,this is what we noticed; Bright with door open, Bright when "ALL" lights on selected on the dimmer, Bright when individually selected with doors closed and ignition ON. DIM only when selecting individual Map Light on with doors closed and ignition OFF. Seriously, how often will you be in that situation? Most times when you need that bright light you will have the ignition on. I learned to live with it for those rare moments instead of trying to rearrainge circuitry.
 

·
Registered
Joined
·
438 Posts
I bought all my LEDs from V-LED and have had zero problems with them. Had them in my 300 for almost 4 years and now my CHallenger for 7 months.
 

·
Registered
Joined
·
15 Posts
They do have all purple (maybe out of stock so they sent red/blue?) the red blue are called matrix. I would return them and get the all purple
 

·
Registered
Joined
·
3,532 Posts
Discussion Starter #11
They do have all purple (maybe out of stock so they sent red/blue?) the red blue are called matrix. I would return them and get the all purple
I just looked at AAC 's website and under Dodge Challenger Interior LED Kit they only show the purple matrix. no straight purple under the challenger section.

but ya, now I see these 44mm LED Bulbs (Pair) which appear to be the right size and are just purple.
 

·
Registered
Joined
·
46 Posts

·
Registered
Joined
·
15 Posts
I just looked at AAC 's website and under Dodge Challenger Interior LED Kit they only show the purple matrix. no straight purple under the challenger section.

but ya, now I see these 44mm LED Bulbs (Pair) which appear to be the right size and are just purple.
Yup I had the red/blue and 1 week latter they posted on another forum they now sell purple . Mine were returned and the new ones look 100x's better
 
1 - 13 of 13 Posts
Top