Dodge Challenger Forum banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
16 Posts
Discussion Starter #1
Big question. I have the sequence kit on my 10 Challenger SE. The headlights lights dim now when I brake or they flicker slightly (dim to bright) when I apply the turn signals. Is this normal?? How can I fix this?? JR
 

·
Premium Member
Joined
·
16 Posts
Discussion Starter #3
I checked the install,, I removed the kit and re installed the kit. Everything done as per instructions.

STILL HAVING ISSUES!!

Is anyone from the company following this site?? I also sent an e mail to the copmpany tech support. NO RESPONSE yet....
 

·
Registered
Joined
·
141 Posts
JRR - Did you ever get a response?
 

·
Registered
Joined
·
1,749 Posts
Was it a web-e kit? Those guys gave me serious attitude when I questioned their product having fault issues, so I bought the mopar kit and it works p e r f e c t l y ! Unless you want to install and uninstall it over and over send it back.
 

·
Premium Member
Joined
·
167 Posts
I know this probably has been answered but I have the same kit on my 10 R/T and all my lights would dim. Interior and exterior. The fix I did was get rid of the phone cord connecting the sides and haven't had a problem since. Also it gives you the feature of having the sequentials work when you hit the lock/unlock on the fob. plus when hitting the brakes they pulse out once from the middle. My problem was that all the brake lights would come on at the same time which would pulse the system. Now that they come on gradually when the brakes are engaged the system can recover. HTH.

Again sorry for bringing up a dead thread but I try to help with what has happened to me.
 
1 - 11 of 11 Posts
Top