Dodge Challenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
I have a 2009 Challenger R/T that was built 08/08/2008. My question is about the traction control button or esp button. If I hold my button in for about 8 to 10 seconds it will make a chime sound. I do not know if this is completly disabling the traction control or not. I do not have track pack or super track pack. And this is not a SRT. Can anyone tell me what this means and why it makes this chime and is it normal for a 2009 RT? I have read on this forum that people with a SRT or a RT with Super Track Pack, the ESP button will chime after holding for about 8 to 10 seconds and that means the traction control is fully disabled. Is this so? What icons on the dash would come on when fully disabled? If this is not normal for my car to do this, I would think that I got a ESP module or button meant for a SRT since my car was built so early. Please let me know any ideas:scratchhead:
 

·
Premium Member
Joined
·
3,554 Posts
I think they must have equiped your car like it had a super trac pac. From what I've read holding the button in on a non stp car will not turn traction control completely off. ON my 10 RT I have to do the key trick or turn the trac control with my predator( put in Dyno Mode).
 

·
Banned
Joined
·
1,540 Posts
That would be cool if they did. So far as I know yours is the only auto that has made a chiming noise as if ESP is completely disabled like on the RT stick cars and the SRT8's. You sure someone didn't install the ESP mod while you weren't looking lol?

Jack
 

·
Registered
Joined
·
2,412 Posts
I have read on this forum that people with a SRT or a RT with Super Track Pack, the ESP button will chime after holding for about 8 to 10 seconds and that means the traction control is fully disabled. Is this so? What icons on the dash would come on when fully disabled? If this is not normal for my car to do this, I would think that I got a ESP module or button meant for a SRT since my car was built so early. Please let me know any ideas:scratchhead:
....speaking as someone with the STP option on my RT and the EVIC display, here's what happens:

From a stop (or not going any faster than 10 mph), press and hold the ESP Off button. The traction control icon will immediately illuminate and after about 10 seconds a chime will sound along with a message on the EVIC that will state" ESP Disabled". A reminder message "ESP Off" will remain. For those without EVIC, I can't tell you for sure what happens. I do know that I don't get the chime by simply pressing the button once (partially disabling traction control). The icon will illuminate regardless though (wither partially disabled or fully).
 

·
Registered
Joined
·
231 Posts
Discussion Starter #5
ESP

Thanks guys for the input. I do have EVIC but it is one that was put in early RTs so I don't get any message saying disabled or off. My EVIC does not tell me that my MDS is on or in economy mode either. When I bought my car I did not know that the EVICS were different in those produced later in 08 and 09. So I will just have to assume it does not have the ability to turn off esp completly since all I get is the esp icon. But sometimes it dissapears after holding button 10 seconds. I do hear the chime. I need to take car to dealer to question gas mileage too because the car is getting bad city mileage. It gets from 9 to 10 mpg city driving but up to 23 on the highway. I would love to get a 2011 Classic with STP or a SRT but can't see trading in my 09 when I have only put 5000 miles on it since purchase 1-2-09. :bigthumb:
 

·
Premium Member
Joined
·
3,554 Posts
Bad city mileage is usually directly attributed to the gas pedal going to the floor to often on mine. LOL
 

·
Registered
Joined
·
2,544 Posts
Mine is an 09. When you push the ESP button and hold it - it turns on Mr Squiggly lines. When you do the Key trick you then get BAS light and THEN it is completely off.
 

·
Premium Member
Joined
·
517 Posts
This happens first.

Then this.
 
1 - 8 of 8 Posts
Top