Dodge Challenger Forum banner

1 - 20 of 325 Posts

·
Moderator
Joined
·
337 Posts
Discussion Starter #1 (Edited)
Hey all,

I was wondering what everyone's 0-60 times have been. Below is a video I took this weekend. I wanted to see how the car would do with my recently installed Blizzak DM-V1's. My best time on the Goodyear 20" rims is 5.85. The car is all stock. No custom anything.

What are your guy's times? Let me know if you have any mods too. Videos would be awesome.

Copy and paste this into your response so we know the details.
Outside Temperature: 37 degrees
Time of Day: 3:30pm
Wheels/Tires: 18" R/T Rims, Blizzak DM-V1's
State/Elevation: Colorado/5,300ft
Auto or Manual: Manual
ESP On or Off: Off
Mods: None

 

Attachments

·
Registered
Joined
·
225 Posts
Got mine to 5.56 last week.

Outside Temperature: ~70-75 degrees (2AM in Austin)
Wheels/Tires: 20" Heritage with stock Goodyears
State/Elevation: Austin, Tx / ~550ft
ESP On or Off: Off

By far my best, most of my other attempts have been 5.8-6.1 range.
 

Attachments

·
Premium Member
Joined
·
517 Posts
Either I have a beast, or the counter is wrong; because I did a 5.14 and a 5.04. I have to go try and take a pic now.
 

·
Registered
Joined
·
225 Posts
Hmm... It would seem I'm doing something wrong then! :p

Granted I haven't had a good place to practice, but if I push it much faster than that I spin (even with ESP on). What are you guys doing and when are you doing it?
 

·
Premium Member
Joined
·
517 Posts
Here's a pic. BTW, I'm still totally stock.
 

·
Premium Member
Joined
·
517 Posts
Hey all,

I was wondering what everyone's 0-60 times have been. Below is a video I took this weekend. I wanted to see how the car would do with my recently installed Blizzak DM-V1's. My best time on the Goodyear 20" rims is 5.85. The car is all stock. No custom anything.

What are your guy's times? Let me know if you have any mods too. Videos would be awesome.

Copy and paste this into your response so we know the details.
Outside Temperature: 37 degrees
Wheels/Tires: 18" R/T Rims, Blizzak DM-V1's
State/Elevation: Colorado/5,300ft
ESP On or Off: Off

YouTube - November 21, 2010 0-60
It sounds like you have a 6 speed. How did you steer, shift, and hold the camera all at the same time?
 

·
Premium Member
Joined
·
423 Posts
5.21 just made it last night (Alameda Naval Base airstrip). Mopar CAI and Diablo tune.

Outside Temperature: 48 degrees
Wheels/Tires: 20" Goodyear stock
State/Elevation: California ~100'
ESP On or Off: On

Best time unmodded was 5.56 but I hadn't been practicing much before getting my first mods. I'm also a 6-spd manual and I know I can probably shave off another tenth if I get my shift timing down better.
 

·
Premium Member
Joined
·
517 Posts
5.21 just made it last night (Alameda Naval Base airstrip). Mopar CAI and Diablo tune.

Outside Temperature: 48 degrees
Wheels/Tires: 20" Goodyear stock
State/Elevation: California ~100'
ESP On or Off: On

Best time unmodded was 5.56 but I hadn't been practicing much before getting my first mods. I'm also a 6-spd manual and I know I can probably shave off another tenth if I get my shift timing down better.
I see I'm not the only night owl here.
 

·
Registered
Joined
·
97 Posts
My PB is a 4.76.

2010 RT Classic. Mods are in my sig. Didn't have the custom tune at the time. Temps were cool at around 10 Celsius. I do have the pic but I'm on my phone at the moment.
 

·
Registered
2016
Joined
·
36 Posts
2010 R/T 20 inch wheels, MODS. CAI and Catback exhaust, outside temp. approximately 65-70, 7:30 a.m.

It takes a lot of pratice, my best time is 5.06. I stopped after ten or so attempts, lots of wheel spin/rubber lost, way to many hard launches. It was a lot of fun though.


I have not made a 0-60 run since the Diablo Predator 93 oct. Tune was installed.
 

Attachments

·
Moderator
Joined
·
337 Posts
Discussion Starter #13 (Edited)
Damn, nice job everyone! It looks like some of you are pulling SRT8 numbers. This is a pretty cool thread. Keep 'em coming.

I think my elevation is adding a second to my time. Seems like all of you in the high 4's are at lower elevations and a bit warmer temps. I hope to have the opportunity to run my car at sea level some time. It'll probably feel like it has a supercharger since I'm not used to it :)

moparman53, yes I have a manual. To shoot the video I used an iPhone in my left hand and shifted with my right. I was on a flat open road so I felt okay doing that.

B5
 

·
Banned
Joined
·
1,992 Posts
Best so far was 5.0 sec flat with my six speed at ~ 1000 ft elevation - I don't have EVIC, but was using my Trinity's virtual drag strip feature.
 

·
Registered
Joined
·
287 Posts
My best time was at Pittsburgh Raceway Park.
About 55*, running drag radials, with mods in signature.
Ran a 60' time of 1.67, 1/4 11.79 @ 114.59.



Brad
 

·
Banned
Joined
·
1,844 Posts
best on a rt auto, 5.46.
75 degrees car warmed to running temp.
lot of wheel spin, think i can get down with some better road.

update, 5.36 still on a bad road lots of tire spin. w/ 91cai tune

update 1/7/11 4.96 with 10" nitto's less tire spin but still have some
 

·
Registered
Joined
·
3,285 Posts
geraldine ... do you have an auto and if so what mod is it to have no ESP?
 
1 - 20 of 325 Posts
Top