Dodge Challenger Forum banner

201 - 211 of 211 Posts

·
Registered
Joined
·
5,897 Posts
Bummer. :( I called Uconnect again and the rep confirmed there is no account linked to my car. I asked if they could reset my system and they directed me to dodge care center 800-423-6343 who helped me reset the system. I then deleted all my info from the head unit, factory reset the system through the engineering mode, installed the Tazer and activated performance pages along with STP. When the head unit restarted I had PP. Drove the car around and they disappeared once I shut the car down and went to restart. This is really frustrating. I am convinced that the 5 year traffic/weather has something to do with it. The kicker is now my sport mode button no longer is linked to the steering mode (or maybe I am imagining that it is supposed to). :crbaby:
it will only link to the steering in a Scat Pack or higher model.
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,000 Posts
it will only link to the steering in a Scat Pack or higher model.
What is interesting is if I activate STP via the tazer, pressing the sport button causes the steering mode to go from sport to normal. Pressing sport again does nothing.

I also noticed I have the 16.16.13 firmware but there is an OTA 17.11.07 that never made it to my vehicle (I read some have lost sport mode with this update).

Supposedly moves the uconnect app button to the center and allows for icon drag and drop.

https://infotainment.freshdesk.com/support/solutions/articles/24000010853-ra3-ra4-17-11-07-update

I swear this uconnect bull is aggravating. :smiley35:
 

·
Premium Member
Joined
·
1,099 Posts
I also noticed I have the 16.16.13 firmware but there is an OTA 17.11.07 that never made it to my vehicle (I read some have lost sport mode with this update).

I called 3 different entities within Dodge about getting the "over the air only" update to 17. (you can not goto that website and download it..it will come up with a message on your NAV screen). All 3 entities said the same things. They SAID they are "rolling out by VIN's" and planed to be done by end of August (hmm? that has come and gone). Also, I forget the details, but the changes that 17 are bringing were not that exciting at all, so little I've lost interest.
There were rumors it would enhance audio sound, but, none of the changes would do this.
I let my Uconnect expire...I never lost anything, however, I've always had TAZOR (2015 Scat Pack)
 

·
Registered
Joined
·
5,897 Posts
If they get rid of sport mode on my 2015 R/T I am getting rid of the car... Dodge can buy it back for disabling the only reason why I bought the car..... (That's my story and I'm sticking to it!)
 

·
Registered
Joined
·
1,391 Posts
Just to add....
Did the 2.4 update on my tazer and everythings working great. I can set custom drive modes, start the car in sport with traction off, easy out, and the one button back to stock all work great. Still no perf pages or shift light though
 

·
Registered
Joined
·
11 Posts
Just to add....
Did the 2.4 update on my tazer and everythings working great. I can set custom drive modes, start the car in sport with traction off, easy out, and the one button back to stock all work great. Still no perf pages or shift light though
I bought the Tazer to activate PP, which it did (2.3.2), it also allows TC off with sport mode button. Canadian car with 8.4 NAV. I did recently had issues with UCONNECT 17.11.07 which broke sport mode, but that is fixed with .37. I haven't played with enough settings, but Launch Control doesn't work with my settings.
 

·
Registered
Joined
·
27 Posts
I've got a 2018 Challenger R/T - it has the newer 7 inch display rather than the older 5 inch display. I assume i'm in the same boat as people with the 5 inch screen when it comes to things that I can do? Like I doubt I can ever get any performance pages on the 7 inch display.... lame
 

·
Registered
Joined
·
10 Posts
What is interesting is if I activate STP via the tazer, pressing the sport button causes the steering mode to go from sport to normal. Pressing sport again does nothing.

I also noticed I have the 16.16.13 firmware but there is an OTA 17.11.07 that never made it to my vehicle (I read some have lost sport mode with this update).

Supposedly moves the uconnect app button to the center and allows for icon drag and drop.

There is no helpdesk here!

I swear this uconnect bull is aggravating. :smiley35:
I recently installed tazer to my car for performed pages and I get them but the gauges don’t read am I’m I missing something only reads battery volts and g force other gages have just two lines - - my car is challenger 2019 stp

I’m my EVIC reads every single one fine
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,000 Posts
I recently installed tazer to my car for performed pages and I get them but the gauges don’t read am I’m I missing something only reads battery volts and g force other gages have just two lines - - my car is challenger 2019 stp
What firmware you running on the tazer? My experience is anything above 2.4.4 was buggy.
 

·
Registered
Joined
·
10 Posts
What firmware you running on the tazer? My experience is anything above 2.4.4 was buggy.
2.8.4 everything else works but not gauges can get street track sport launch guage reading in EVIC but not radio weird idk if I have to go into UConn’s the change something or what did battery reset Took out fuse reboot nothing
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,000 Posts
2.8.4 everything else works but not gauges can get street track sport launch guage reading in EVIC but not radio weird idk if I have to go into UConn’s the change something or what did battery reset Took out fuse reboot nothing
Try 2.4.4. BTW there is a 2.4.9. I have tried 2.4.5 (there were 2 versions - 1st one did not work at all and 2nd did but jumped to 2.4.6). 2.4.6 would cause the eco light to come on in the dash which was weird because have a manual, no MDS. After that I went back to 2.4.4. Not going to a higher firmware unless there is a new feature worth upgrading to.
 
201 - 211 of 211 Posts
Top