Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Registered
2019 Dodge Challenger SXT blacktop
Joined
·
1 Posts
Discussion Starter #1
So I've recently installed brand new Oracle Lighting Headlights, Fog Lights, and DRL-Colorshifters onto my 2019 Dodge Challenger SXT. The vehicle isn't even 3 months old and after all installations, I'm receiving a rapid left turn blinker with error message stating that the light is out when it's not at all. Disconnected the negative from the battery and let it sit for 30mins. Once I reconnected, restarted the car and it disappeared until I started driving over an hour later, but the blinker comes on just fine. What do I do??
 

·
Premium Member
Joined
·
2,224 Posts
If everything works correctly, regardless if you get error message or not, I would be lazy and not do anything. As long as you know everything is working, ignore the error message.

I know it has to do with the resistance the circuit sees once you turn on the turn signal. I can't offer up any advice though. I installed sequential turn signals on the rear of my 2013 SXT. 98% of the time, they worked fine. Then I would get the rapid flashing on one side or the other, but when I got home and looked, everything was working as it should.
 

·
Super Moderator
Joined
·
14,837 Posts
you probably need load resistors to get the correct value. the turn signal flash rate is controlled by circuits in the IP cluster (there's no blinker relay like older vehicles would have)
 
1 - 4 of 4 Posts
Top