Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
1,546 Posts
Discussion Starter · #1 ·
So this is usually a straight forward process from what i thought, however,

I installed my newly acquired pettys garage rear strut brace with the nyloc nuts. Initially when installed it, THE SHOCK STUDS BACKED THEMSELVES OUT. Immediately i heard a loud rattling and didnt go far.

Re-installed with the cup washers that were provided in what i assume was the correct fashion (their instructions suck btw) , and now after tightening some new nyloc nuts while holding the bottom of the shocks studs/bolts, there is still a loud rattling coming from one side. Nothing feels loose with the tool all tight. I loosened everything once more and re-torqued it all and THE OTHER SIDE IS RATTLING NOW.


Any input is appreciated
 

·
Registered
Joined
·
988 Posts
Do what I did... Use std nut and drill and tap it for a set screw. Now put all together with blue loctite and forget about it.

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
988 Posts
I had Razors Edge version. They had "cups" for spacers. They were not heavy enough a collapsed when I cranked them down. So, had to modify the setup which resulted in my mod.

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
1,546 Posts
Discussion Starter · #5 ·
I had Razors Edge version. They had "cups" for spacers. They were not heavy enough a collapsed when I cranked them down. So, had to modify the setup which resulted in my mod.

Sent from my LM-Q710.FG using Tapatalk


Ahh...yeah the pettys also uses the cup washers. Man seems like a heavy mod to tap the holes... theres gotta be another way without modifying ?
 

·
Registered
Joined
·
10,167 Posts
Just an FYI, only use a nyloc nut once.

I had zero problem when I installed the Petty rear brace on mine.

Not sure what's going on with your noise after the install.
 

·
Registered
Joined
·
988 Posts
It takes maybe 5 mins to drill and tap. Of course I have a drill press and full tap set.

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
1,546 Posts
Discussion Starter · #8 ·
Just an FYI, only use a nyloc nut once.

I had zero problem when I installed the Petty rear brace on mine.

Not sure what's going on with your noise after the install.


Bought a bag of 50 just incase i used all new nuts


Im afraid i may a fudged something when i did the initial install with the cups upside down, maybe opened up the stud hole on the top mount of the strut? Have to go back and check
 

·
Registered
Joined
·
1,546 Posts
Discussion Starter · #9 ·
Alright folks problem solved....the answer,....

120 ft/lb impact gun on the bottom studs coming up! I thought i got then tight enough by hand but using the impact i got a solid 10 more turns and it is solid now, hammered down both sides and im good.
 

·
Registered
Joined
·
10,167 Posts
Good to hear, or actually not hear the noise.

Run it hard!
 
  • Like
Reactions: trippytro
1 - 10 of 10 Posts
Top