Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, I'm new to the site, so bare with me. I have an 09 challenger R/T and just recently started having an issue when I come to a complete stop, the rmps drop to 500 in drive. If I tap on the gas, it revs back up to normal and then slowly will drop back down to 500. In park, reverse and neutral it's normal. Maybe the throttle body or sensor? Please help!
 

·
Registered
2020 Dodge Challenger Hellraisin Scat Pack
Joined
·
3,739 Posts
Hey guys, I'm new to the site, so bare with me. I have an 09 challenger R/T and just recently started having an issue when I come to a complete stop, the rmps drop to 500 in drive. If I tap on the gas, it revs back up to normal and then slowly will drop back down to 500. In park, reverse and neutral it's normal. Maybe the throttle body or sensor? Please help!
Is there a throttle calibration procedure documented in the owners manual? Or search for one for your MY car. I'd try that first if there is one of course.

Absent some other explanation could be the early warning sign of a bad fuel pump.

Is the engine in reasonably good "tune"? Fuel filter, engine air filter, plugs, all not past their change by date or miles?
 

·
Registered
Joined
·
3,565 Posts
Try a new crank position sensor or cam position sensor both easy to switch

Also is this a clutch car? If so the older ecm had issues with this

Sent from my SM-G960U using Tapatalk
 

·
Registered
2014 Shaker Boosted 392 Stroker M6
Joined
·
3,006 Posts
Before doing anything else, run a couple of tanks of 91 octane gas with Techron through it...
 
1 - 4 of 4 Posts
Top