Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hi I have a 09 challenger SE with the Mopar sequential tailight kit.
I had a bulb burn out on left side second from the left. Replaced bulb now the only bulb sequencing is that far left bulb. The other 3 bulbs just flash together at the same time.
Anyone have any ideas?
 

·
Premium Member
Joined
·
2,329 Posts
I'm not going to be of much help here. I only have experience with Web Electrics sequential tail lights, so I don't know if they are the same as Mopar's.

Basic questions... Do the front turn signals flash normally? Did you replace the tail light bulb with the same number bulb that was in there originally? (I had to ask)

Maybe you have more than that one burned out bulb?

I just know with Web Electrics, it would go wonky once in a while and flash fast like a bulb was burned out. Then once I shut the car off, it would reset itself and all was good.

The last thing I can think of is the control module of the sequentials might have gone crazy on you.
 

·
Registered
Joined
·
14,269 Posts
Im thinking the sequencer module too. Might be able to find one on EBay or something, parts for these no longer available from Mopar.


Sent from my SM-N920T using Tapatalk
 

·
Super Moderator
Joined
·
15,339 Posts
its likely the sequencer module went out.

The mopar kit looks virtually the same as the Web Electric - so you could probably try swapping out that side.

Chrysler had issues with keeping up with the supply and then eventually discontinued offering it.
 

·
Registered
Joined
·
1,070 Posts
If I recall correctly the Mopar branded sequential kits were discontinued due to a high defective rate and not inventory problems. I might be remembering it wrong too...
 
1 - 5 of 5 Posts
Top