Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi
Help required
i have got a 2018 challenger 3.6 and sometimes when starting the car a engine warning light come's on and the display says Service shifter, it then will not come out of park, it will show on the display as moving to drive etc etc, but will not got into gear, this doesn't happen all the time just every now and again,the last time i disconnected the battery and it didnt make a difference, in the end i removed the shifter cover and wiggled a few wires on the shifter assembly, and it went into gear.

Has anyone had this happen and how do i fix this.

Also i live in Nottinghamshire, and wondered if there is a garage around near me that does work on challengers.

regards

Steve H
 

·
Registered
Joined
·
2,422 Posts
Hi
Help required
i have got a 2018 challenger 3.6 and sometimes when starting the car a engine warning light come's on and the display says Service shifter, it then will not come out of park, it will show on the display as moving to drive etc etc, but will not got into gear, this doesn't happen all the time just every now and again,the last time i disconnected the battery and it didnt make a difference, in the end i removed the shifter cover and wiggled a few wires on the shifter assembly, and it went into gear.

Has anyone had this happen and how do i fix this.

Also i live in Nottinghamshire, and wondered if there is a garage around near me that does work on challengers.

regards

Steve H
Based on what you wrote it would appear the Service Shifter message is an electrical connection/wiring issue. The engine or transmission controller is failing to get a signal the shifter is not in the position expected.

You can check for a broken wire or a wire that is loose where it goes into a connector. Also check the wiring harness is routed correctly, secure, and the wires are not rubbing/chaffing.

Less likely but possible is rodent damage to the wiring.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Based on what you wrote it would appear the Service Shifter message is an electrical connection/wiring issue. The engine or transmission controller is failing to get a signal the shifter is not in the position expected.

You can check for a broken wire or a wire that is loose where it goes into a connector. Also check the wiring harness is routed correctly, secure, and the wires are not rubbing/chaffing.

Less likely but possible is rodent damage to the wiring.
Hi Thank you for the reply, do you think the best place to start is around the shifter.

Also do you know of any garages near Nottinghamshire that works on Dodge cars, ive been to my local garages and they dont seem to want to get involved, i dont mind travelling to get the problem sorted.

Steve
 

·
Registered
Joined
·
75 Posts
Steve, have you found the UK Facebook page for Challengers - funnily enough called "UK Dodge Challenger"

I'm in Yorkshire, but there do appear to be a number of owners in your area, so I'm sure someone could make a suggestion. Not sure too many people in the US are going to know where you are, never mind know anyone willing to work on your car :)
 

·
Registered
Joined
·
2,422 Posts
Hi Thank you for the reply, do you think the best place to start is around the shifter.

Also do you know of any garages near Nottinghamshire that works on Dodge cars, ive been to my local garages and they dont seem to want to get involved, i dont mind travelling to get the problem sorted.

Steve
That you had some positive effect on the behavior after removing the shifter cover and wiggling some wires in that area I'd say under the shifter cover would be the place to start.

Sorry I'm in the US and have no clue regarding any UK shops that might be able to help you with your car.

Oh, you can visit the Piston Heads web site. It has a section, American Cars, Yank Motors. Post question there asking for any shop recommendations.
 
1 - 5 of 5 Posts
Top