Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I was detailing my car this evening listening to the radio on accessory. It timed out and shut off and I had just finished so I jumped in to start it and it wouldn't start. The car made a clicking type noise sort of like with the old cars when your starter is shot. The start button then stayed on run even though it wasn't running. Couldn't shut it off by pressing the button either. Only stayed on run. Dash lights were on telling me to press the brake and press start. Check engine light was on also. At one point the check engine light was flashing. Radio and AC worked but couldn't wind up the windows. Halos were on and wouldn't shut off. Tried disconnecting the battery, tried starting with the fob to the start button - nothing changed. Tried jumping it too. Put her on the charger as well. Same symptoms. Factory battery still and she is a 2015 so thinking maybe something with the battery? She is dead in the driveway with windows down right now so I covered her up with her dust cover and a tarp over that since we have a freeze warning tonight. Will have to call in the morning to have her towed to the dealer if I can't figure this out. (She is a 2015 SXT.)
 

·
Registered
2016 R/T Scat Pack
Joined
·
1,521 Posts
Hold the key fob against the start button for 10-15 seconds to let it “read”. It may not be detecting it and not letting it start.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
Hold the key fob against the start button for 10-15 seconds to let it “read”. It may not be detecting it and not letting it start.


Sent from my iPhone using Tapatalk
I did try that but maybe I didn't hold it against it long enough? I had the dealership on the line with me so I think I just held it there and pushed the button with it. I'll try to hold it there longer in the morning and see what happens. Thanks!
 

·
Registered
2015 SRT, 6 Speed, Sublime Green
Joined
·
2,086 Posts
Disconnect the battery for five minutes. Wait. Reconnect. Sounds goofy, but may clear whatever “error” is going on. That clicking is a classic sign of low voltage in the battery.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
Disconnect the battery for five minutes. Wait. Reconnect. Sounds goofy, but may clear whatever “error” is going on. That clicking is a classic sign of low voltage in the battery.
It was disconnected for about an hour. I was hoping the same.
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,705 Posts
Yeah, step one, ALWAYS check battery voltage first on a no crank issue. I bet it is below 12. If when running it is well over 13, 14 after start up, and battery is 5+ years old, I'd replace it just to be safe.
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,705 Posts
I was detailing my car this evening listening to the radio on accessory. It timed out and shut off and I had just finished so I jumped in to start it and it wouldn't start. The car made a clicking type noise sort of like with the old cars when your starter is shot. The start button then stayed on run even though it wasn't running. Couldn't shut it off by pressing the button either. Only stayed on run. Dash lights were on telling me to press the brake and press start. Check engine light was on also. At one point the check engine light was flashing. Radio and AC worked but couldn't wind up the windows. Halos were on and wouldn't shut off. Tried disconnecting the battery, tried starting with the fob to the start button - nothing changed. Tried jumping it too. Put her on the charger as well. Same symptoms. Factory battery still and she is a 2015 so thinking maybe something with the battery? She is dead in the driveway with windows down right now so I covered her up with her dust cover and a tarp over that since we have a freeze warning tonight. Will have to call in the morning to have her towed to the dealer if I can't figure this out. (She is a 2015 SXT.)
JUmp pack/Jumper cables, will get your windows up, if not car started, but your battery is almost guaranteed to be dead, but might come back after running a bit.
BTW, where in the USA are you with a Freeze Warning now?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #9 ·
JUmp pack/Jumper cables, will get your windows up, if not car started, but your battery is almost guaranteed to be dead, but might come back after running a bit.
BTW, where in the USA are you with a Freeze Warning now?
Battery was the issue. Wrecker driver was able to jump it with a pack and it started so I could drive it in to the dealer. They tested the battery at the shop and the entire charging system. No issues except the battery. I'm in NE Minnesota, close to the Canadian border and we've had frost every morning this week. Thanks for all your help!
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,705 Posts
Battery was the issue. Wrecker driver was able to jump it with a pack and it started so I could drive it in to the dealer. They tested the battery at the shop and the entire charging system. No issues except the battery. I'm in NE Minnesota, close to the Canadian border and we've had frost every morning this week. Thanks for all your help!
Cool, a few years ago I did a figure 8 around Superior and Huron. 3200 miles in 8 days. I went clockwise around Superior, stayed in Angle Inlet 2 nights for kicks. Nothing like driving through Canada to get to USA.
And the weird thing, the cabins didn't have A/C and it was over 90° the entire time.
End of July 2016 in my SLK350, 2200 miles straight top down, then switched off and on with the roof up. I went as far as Winnipeg.
As I arrived back in USA after going through Canada...
1002472

As I arrived at the cabins
1002473
after driving about 30 miles on dirt roads cutting up towards Winnipeg
1002470
I saw this in Wisconson
1002471
 
1 - 10 of 10 Posts
Top