Dodge Challenger Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
radio requested software update, at first I ignored it, then it kept coming up over and over again, so I did just as instructed, leave engine running 15-20 mins, do not interrupt or it will start over from beginning next time, after time lapsed instructions stated I can turn engine off since install and updating could take up to 58 mins, I again did as instructed, next day I get a warning light and display to have my electronic stability control system and ABS serviced, I also no longer had cruise control, when calling DODGE technical support who instructed me to restore default through my app setting to no avail now says take it to the dealer, I do have cruise control back, curious if anyone else has experienced this issue, car isn't even 3 years old and you do what they instruct you and now you have glitches
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
radio requested software update, at first I ignored it, then it kept coming up over and over again, so I did just as instructed, leave engine running 15-20 mins, do not interrupt or it will start over from beginning next time, after time lapsed instructions stated I can turn engine off since install and updating could take up to 58 mins, I again did as instructed, next day I get a warning light and display to have my electronic stability control system and ABS serviced, I also no longer had cruise control, when calling DODGE technical support who instructed me to restore default through my app setting to no avail now says take it to the dealer, I do have cruise control back, curious if anyone else has experienced this issue, car isn't even 3 years old and you do what they instruct you and now you have glitches

Welcome to the forum. What year challenger? Also what software version did it update to?
 

·
Premium Member
Joined
·
3,029 Posts
Welcome to the forum and welcome to the world of what IT does for you!:frown:
 

·
Premium Member
2016 SRT
Joined
·
458 Posts
Welcome to the forum and welcome to the world of what IT does for you!:frown:

Or to you!!


Could be a coincidence and a wheel speed sensor went out. That's what happened to my 15 SRT with the same symptoms. No software update in my case tho. Sensor was replaced under warranty.


Good luck and welcome to the forum!
 

·
Registered
Joined
·
1,549 Posts
How do you know if you need a software update, if you're not "connected" to any service with your UConnect.

I've had mine for 5 years, and have never done any software updates? Are they available for download? Plug into the USB? Do I need any for my 2013?
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
How do you know if you need a software update, if you're not "connected" to any service with your UConnect.

I've had mine for 5 years, and have never done any software updates? Are they available for download? Plug into the USB? Do I need any for my 2013?
Enter your vin here:
https://www.driveuconnect.com/support/software-update.html

If you log into this online drive, there might be a TSB in one of the folders along with the corresponding firmware update but I would "trust" the uconnect site.
http://www.challengertalk.com/forums/1837050-post1.html

My wife's 2013 GC had an update which I downloaded from the uconnect site. Required the car to be on and took more than an hour!
 

·
Registered
Joined
·
1,549 Posts
Interesting. My Car has an update to address a service bulletin regarding hands-free operation not working with bluetooth devices. Oddly enough, when I got my latest flip phone (yes a flip phone), the hand-free dialing works, but only if I call out the actual telephone numbers. My old phone, I could just call out "Call Home", or "Call Wifey" and it would access the address book on the phone and make the call. When I got this new (old/new) phone, that functionality didn't work (I figured it was just an issue with the phone.). It will recognize voice command "Dial 724-555-1212", but not "Call Home". Oddly enough, the UConnect in the 2016 RAM does work with the names in the same phone's address book.

If my dealer ever gets back to me with my alternator recall part, I'll probably just have them do it.
 

·
Registered
Joined
·
716 Posts
Its really interesting reading all these updates and how they seem to do more damage than good. I won't let my car take an update. Don't care for one, what's it going to update anyway??? Does anyone know what the goal of these updates are?? Car drives perfectly, all controls work as they did from the factory, why mess with it? For navigation?
 

·
Registered
Joined
·
1,549 Posts
If your car is no longer under warranty, they may charge you for the update as it is a TSB and not a recall.
Well I figured as much. Since my TSB specifically relates to an issue I'm having hand's free operation, I'll probably try it myself. The car will be garage-bound for a few days while some snow and icy weather blows through. Maybe try it this weekend.
 

·
Registered
Joined
·
1,549 Posts
Its really interesting reading all these updates and how they seem to do more damage than good. I won't let my car take an update. Don't care for one, what's it going to update anyway??? Does anyone know what the goal of these updates are?? Car drives perfectly, all controls work as they did from the factory, why mess with it? For navigation?
There are updates to address identified vulnerabilities, like the one I have with some hands-free functionality through blue-tooth. Then there are the other ones for Navigation. I think the bug-fix updates are free. The NAV updates are not. They wanted $147 to update the NAV system.

I told them to go pound sand for $147 and that my new 2018 Rand McNally Atlas needs no power, satellite connectivity and works even when the UConnect doesn't. Told them if they'd offer the NAV update for the same $18 that I paid for my Atlas, I'd consider it as a back up in case my Atlas ever fails. I never heard back.
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
Well I figured as much. Since my TSB specifically relates to an issue I'm having hand's free operation, I'll probably try it myself. The car will be garage-bound for a few days while some snow and icy weather blows through. Maybe try it this weekend.
BTW it is the +2015 uconnect radios that seem to suffer from update woes.
 

·
Registered
Joined
·
410 Posts
I think this is the update I just got on my 2016 Scat Pack. Its got to be an update AFTER the May 2017 17.11.07 version which I already had installed. This update just bricked my Uconnect also.
 

Attachments

·
Registered
Joined
·
178 Posts
How do you know if you need a software update, if you're not "connected" to any service with your UConnect.

I've had mine for 5 years, and have never done any software updates? Are they available for download? Plug into the USB? Do I need any for my 2013?
Given everything we read on the forum about this updates, seems a lot better to leave the unconnect services disconnected, I for one don’t give a $hit about uconnect and absolutely anything they have to offer, it’s scary to know how what it seems just like a normal car stereo is totally controlling part of the car brains, I don’t have uconnect services, and haven’t been bothered with this updates.
 

·
Registered
Joined
·
468 Posts
I entered my vin# and it says its up to date,even though my uconnect is version 16.33.xx. what ups what that? 2016 scat pack shaker.
 

·
Registered
Joined
·
410 Posts
Wait didn't you say in another thread it fixed your sport mode?
http://www.challengertalk.com/forums/8116754-post696.html

Yup. So it was bricked between Thursday and Saturday (last night). Last night I went to the store and it was still bricked. But when I got back in my car by some miracle is was working. Speakers came on automatically, the update box wasn't stuck on the screen and then I immediately checked the sport mode setup and it was fixed. IDK wtf happened.
 

·
Registered
Joined
·
194 Posts
radio requested software update, at first I ignored it, then it kept coming up over and over again, so I did just as instructed, leave engine running 15-20 mins, do not interrupt or it will start over from beginning next time, after time lapsed instructions stated I can turn engine off since install and updating could take up to 58 mins, I again did as instructed, next day I get a warning light and display to have my electronic stability control system and ABS serviced, I also no longer had cruise control, when calling DODGE technical support who instructed me to restore default through my app setting to no avail now says take it to the dealer, I do have cruise control back, curious if anyone else has experienced this issue, car isn't even 3 years old and you do what they instruct you and now you have glitches
Count your blessings. I only had my car 60 hours before it had to go in for service. A month later, it was half-fixed.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,634 Posts
I entered my vin# and it says its up to date,even though my uconnect is version 16.33.xx. what ups what that? 2016 scat pack shaker.
It always said up to date for me as well, even though I knew there was a newer version. BUT, the newer versions are all OTA, so I assume the site is showing what can be downloaded is up to date. A Guy
 

·
Registered
Joined
·
1,549 Posts
I did the VIN search, and found an update for my 2013 Uconnect (730?). Apparently, and issue with voice activated commands. So I download the update to a USB stick, attempt to follow the directions that came with it, and.....right off the bad, the system doesn't recognized the voice command "Software Update", that was included in the instructions. Could find no way to do the update by pressing buttons. No other instructions for the update were available.

Does anybody think it's shortsighted to do an update for a problem with voice recognition, and all of the update instructions are done.......by voice commands?
 
1 - 20 of 38 Posts
Top