Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
Is there any truth to these cars (automatic) having wheel hop problems as they come from the factory ? If so what do I have to change to eliminate the problem ? What is the RPM redline on the 6.4 Hemi? Does the factory have limiter preset? Anything else I should know about this combo ! I've got a couple of 426 Hemis, but these are new to me ! I haven't got the car yet, it is in JB status whatever that means ! Any help is much appreciated........Thanks John
 

·
Banned
Joined
·
1,540 Posts
Hey John, love your work, got all your albums lol J/K. Haven't heard of any wheel hop probs on any auto Challenger, somebody chime in here if i'm wrong. The factory has had limiters on the R/T and SE models for mph, I believe the factory still has the RPM's preset so you don't sneeze the engine. There are a couple of owners on this forum who have their IE 392's and they may be able to give some insights. JB status is being shipped to upfit center for striping. After that, storage then it begins its journey to you. Congrats on your car and post pics when it arrives!

Jack
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
Jack09

Jack , Just to let you know , I found out today that my car is on the truck and on its way to customs ! I guess nobody has any info on the 6.4-392 Hemi, as in nobody other than you replied ! The dealer did mention that he had a dozen dealer calls to trade for my car due to the color combination it is ! I'll keep you informed as to whats going on !...........John
 
1 - 3 of 3 Posts
Top