Dodge Challenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I just received a new SRT oil filter for my Scat pack. No damage to it whatsoever, but the O-ring isn't adhered to the filter. It sits in the groove for it fine, but every filter i've ever bought, the gasket was always glued/attached to the filter body.

Is it defective, or is this typical of the SRT filters?

Thanks
 

·
Super Moderator
Joined
·
14,795 Posts
the glue probably wasn't applied properly during assembly. As long as you make sure the gasket is centered when you install it is the important part.

I always start the engine and check for leaks before putting the belly pan back on - just as a precaution.

cold oil @ 55-60 psi on startup will find an opportunity to leak (or spray out) if it wasn't on right
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
Thanks for the response. I think I'm just going to exchange it with Amazon and get a new one just to be safe. I guess I'm sort of anal about that. I wasn't going to change my old till this Friday anyways.

Thanks again for the response.
 

·
Registered
Joined
·
1,962 Posts
your filter is all good. apply a little (very little) film of vasaline to it to help it stick during install and lube it so it doesnt tear/rip.
 

·
Registered
Joined
·
13,950 Posts
Agree, or can use a little wheel bearing grease to stick the gasket if need be, absolutely no reason to return that filter.


Sent from my SM-N960U using Tapatalk
 
1 - 6 of 6 Posts
Top