Dodge Challenger Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
13 speakers plus a sub... :thumbsup:
Ok,, so where in the hell ARE the speakers...
I found two in dash,, two door, two in package shelf..
And the rest are,,,,,,,,,,,,,,,,,,,, where ....?? :scratchhead:

The sub in trunk is not one of the 13...
 

·
Registered
Joined
·
1,077 Posts
If I'm not mistaken (I haven't looked too closely) but isn't there 3 in the dash? Also they other 6 may be compoent speakers with a seperate woofer and tweeter. If so those 6 you found are actually 12. :)
 

·
Premium Member
Joined
·
2,797 Posts
the three dash speaker are coax speakers = 6 speakers
then one in each door = 2 speakers
then two coax speakers in the parcel shelf = 4 speakers
then the 10" sub = 1 speaker

total 13 speakers
 

·
Premium Member
Joined
·
1,722 Posts
I guess the 2012 is supposed to have 19 speakers and a bigger amp. I am sure they Will double or triple up speakers in the current locations.
 

·
Registered
Joined
·
1,077 Posts
S/S Dodge has the right answer. Not how I would count speakers. Kind of misleading to me.
Agreed coaxial speakers does not equal 2 different speakers.
 

·
Registered
Joined
·
1,658 Posts
After all this time, I can't believe they haven't fixed the "Thump" -ing sound the sub makes when the car off. These speakers did it in my '06 Charger SRT8 and now in my '11 Challenger SRT8. 6 model years - issue still exists. (That's progress :rolleyes:)
 

·
Registered
Joined
·
1,658 Posts
What thumping sound is that?
Many SRTs order with the Sound Group II used to (well still do) have an intermediate "thump" when you sat in the cars after turning them off. About every 2-5 minutes.

If you search some of the other LX and LC forums you should be able to find many threads on this issue. Either search "thump" or "trunk monkey".
 

·
Registered
Joined
·
211 Posts
Many SRTs order with the Sound Group II used to (well still do) have an intermediate "thump" when you sat in the cars after turning them off. About every 2-5 minutes.

If you search some of the other LX and LC forums you should be able to find many threads on this issue. Either search "thump" or "trunk monkey".

Thanks. I do hear this occasional thump when the car is off and wasn't sure what to make of it. :bigthumb:
 

·
Registered
Joined
·
653 Posts
That's really weird I'll have to listen for it tomorrow when I get my 392.
 

·
Super Moderator
Joined
·
15,559 Posts
Many SRTs order with the Sound Group II used to (well still do) have an intermediate "thump" when you sat in the cars after turning them off. About every 2-5 minutes.

If you search some of the other LX and LC forums you should be able to find many threads on this issue. Either search "thump" or "trunk monkey".
The Kicker 10" (SRT) sub amp is supposed to power down when there's no signal present - "remote power up/down".
There's been a couple of posts in the past where the SRT models would run the battery down due to the sub amp staying powered up continuously.

I an number of instances, the subwoofer amp module was replaced to correct the symptom.

The random "thump" is a sign that the sub amp is still powered up.
 

·
Registered
Joined
·
1,658 Posts
The Kicker 10" (SRT) sub amp is supposed to power down when there's no signal present - "remote power up/down".
There's been a couple of posts in the past where the SRT models would run the batter down due to the sub amp staying powered up continuously.

I an number of instances, the subwoofer amp module was replaced to correct the symptom.

The random "thump" is a sign that the sub amp is still powered up.
Thanks Hal!

I'll go by the dealership today (local dealership: not the one I bought the car from :fight:) and see if they'll fix it.
 

·
Registered
Joined
·
1,077 Posts
I've only ntoiced it when my keyfob is near the car. I have to test this more this weekend.
 

·
Registered
Joined
·
1,658 Posts
I've only ntoiced it when my keyfob is near the car. I have to test this more this weekend.

Yeah, it may have something to do with this "proximity" key-fob crap.

Don't, I mean, don't wash your car with the key-fob in your pocket! The car will flash and bling uncontrollably as you approach and step away from the car. Yikes!!
 

·
Registered
Joined
·
353 Posts
Many SRTs order with the Sound Group II used to (well still do) have an intermediate "thump" when you sat in the cars after turning them off. About every 2-5 minutes.

If you search some of the other LX and LC forums you should be able to find many threads on this issue. Either search "thump" or "trunk monkey".

I had it in my 10 and I still have it in my 11. It doesn't bother me but it's definitely noticeable.
 

·
Registered
Joined
·
1,077 Posts
I tested this out three times for 10 minutes this weekend where I walked up to the garage without the keyfob with me. 0 thumps after three times.
 

·
Registered
Joined
·
1,931 Posts
Damn! The thumping when I was sitting in the car...with engine off...I thought someone was kicking the floor...or seats...or it was part of those little voices in my head!!
It was thestrangest thing...everytime i'd move...ot touch something on the dash...it would thump!
Probably a good idea to leave a Battery Tender hooked up if you don't use the car everyday. Which leads me to my next discovery....plugged the Battery Tender (I have cig lighter adapter) into main power outlet in dash....& it kept flashing red...which means it's not connected properly....so i tried the aux outlet in console....guess what?...same thing! and i know it's not the BT, since it works in my other car.
 

·
Registered
Joined
·
1,658 Posts
Damn! The thumping when I was sitting in the car...with engine off...I thought someone was kicking the floor...or seats...or it was part of those little voices in my head!!
It was thestrangest thing...everytime i'd move...ot touch something on the dash...it would thump!
Probably a good idea to leave a Battery Tender hooked up if you don't use the car everyday. Which leads me to my next discovery....plugged the Battery Tender (I have cig lighter adapter) into main power outlet in dash....& it kept flashing red...which means it's not connected properly....so i tried the aux outlet in console....guess what?...same thing! and i know it's not the BT, since it works in my other car.
The power outlet circuits are "opened" when you shut off your car and open your doors: no electrical current flow possible. Not having the circuit "closed" prevents your Battery Tender from "reaching" your battery to begin the trickle charge...
 
1 - 20 of 23 Posts
Top