Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Having multiple column issues, 2010 RT no evic, stereo, cruise, horn, & wiper control. Do have turn signals, washers, & high speed wipers with out home feature.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
8,601 Posts
How many miles on the car?

Have you recently had any work done on the steering column, e.g. had the airbag recall performed at a local dealership service department?

The missing functionality seems awful localized to just suddenly go on the fritz. It seems like something would proceeded it (and ultimately contributed/caused it).
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
33000 mi. I did have the air bag recall performed but the problem was there before that. Just bought car & to excited to check out everything. All I saw was blue bueaty at 33000 for 13500. Being a mechanic I figured I could fix anything that cropped up.

Been t/s wiper issue no intermittent or slow speed just wide open with no park feature. Found two relays under hood with 4 pins , the fuse lid States 5 pin only, could this be my problem?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
I believe the wiper issue is separate from evic, radio & all other steering wheel controls. I hear clock spring issues can effect some controls & not others
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
The wiper issue was repaired with the proper relays & cruise control was taken care of with new switch. Now it's just steering wheel controls , horn & of course air bag probably would not deploy if needed. The horn & evic are my main wants , to ward off idiot drivers & to fine tune my ride options.
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy
Joined
·
3,699 Posts
Clockspring is likely first place to look.
 
1 - 6 of 6 Posts
Top