Dodge Challenger Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
6,279 Posts
Discussion Starter · #1 ·
Alright, so I've been trying to get my factory intake back on and ran into some trouble. I can't seem to get the damn thing to click in. If you've taken off your intake, theres the bottom with the filter and the top which leads to the throttle body. Has anyone else had trouble getting the filter to connect back together? It has two tabs on the side closest to the nose of the car that WILL NOT click back in. I'm sitting in my garage as we speak because I need to get this damn thing together, I haven't had the car out since october and I NEED to get this thing on the road again its killing me.
 

· Registered
Joined
·
6,279 Posts
Discussion Starter · #2 ·
Anyone? Noone change their filter on the stock intake? Anyone thats pulled it off for a CAI and didn't like the replacement? I'm stuck here guys and its such a nice day I just want to get this thing out
 

· Registered
Joined
·
862 Posts
Are you trying this in the engine bay or out? If you have it out you could
have a bit more down force to get it closed. If your already doing it that
way, wow, not sure what would help, a different filter??

I have a K&N in mine and check it frequently, never a problem closing.
 

· Registered
Joined
·
6,279 Posts
Discussion Starter · #6 ·
Yeah tried in, and out. I'm bout ready to just go buy a k&n but I'm only putting this in temporarily, so its more or less a waste. Oh well, looks like thats about my only option. Thanks for tryin though, definitely helps knowing I'm not doing something wrong it just seems to not close
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top