Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
I'm on my second round of amps and speakers now. I added a 1200 watt Rockford amp thanks to a friend that works there, a LOC, and upgraded my subs to alpine 10" DVC subs that handle 600 watts RMS. I figured these upgrades would make some serious bass and make me happy. The previous amp was 500 watts and speakers were 250 watt SVC.

Unfortunately, I barely notice anything. In fact, you can barely notice between the subs on and not on. I don't know what is up. I am assuming the trunk is just a vault of bass absorption since the speakers are moving alot. It just isnt translating into bass in the cabin. Makes me wish I had gone with 12"s.

Anyone else ever get 2 10's to sound good in the cabin?
987471
987472
 

·
Premium Member
2012 Charger Pursuit
Joined
·
5,569 Posts
Fold down the passenger side rear seat back. Is there a significant diff now?

If no, other things can be checked, but if it’s just a matter of sound wave absorption, that should tell you.

Also, is the box sealed or ported?

which way is it facing, toward front of car or toward rear (or sideways firing, etc)?
 

·
Premium Member
2012 Charger Pursuit
Joined
·
5,569 Posts
I will say that my initial thought upon reading about your problem was one of sub wiring inside the box. I had the same symptoms afflict me when helping my brother install 2 tens in a box in my brother’s Camaro. It turned out that I had wired one of the subs backwards during box assembly. The result was that the suns were out of phase with each other.

That does a hell of a job to cancel out just about any bass being produced.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #4
You were right Nuke. As I loaded the subs in the box I flipped the wires on the second sub. I get a dumb ass award. This is stuff I. Normally don't miss. Needless to say, 1200 watts into these 2 10's pounds pretty good now. I had to remove the LOC because it wouldnt pass a good signal. Surprisingly to high level inputs on the RF amp work great. The amp gain is set to about 3. I'd recommend this setup to anyone that want some nice bass with their Alpine 6 speaker. Very easy to add with everything in the trunk.
 

·
Premium Member
2012 Charger Pursuit
Joined
·
5,569 Posts
You were right Nuke. As I loaded the subs in the box I flipped the wires on the second sub. I get a dumb ass award. This is stuff I. Normally don't miss. Needless to say, 1200 watts into these 2 10's pounds pretty good now. I had to remove the LOC because it wouldnt pass a good signal. Surprisingly to high level inputs on the RF amp work great. The amp gain is set to about 3. I'd recommend this setup to anyone that want some nice bass with their Alpine 6 speaker. Very easy to add with everything in the trunk.
Happens to the best of us, glad to hear you got it figured out!
 
1 - 5 of 5 Posts
Top