Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi everyone! I wanted to know if anyone out there with launch control on their SXT Challengers are having an issue with setting the rpm higher than 1000? I’m currently unable set it higher than that. Please let me know if that is how it is or if there is fix or update? I went to the dealer already and didn’t know... I appreciate the feedback and help!:smile:
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,803 Posts
Does the setup just not let you set it over 1000? Or does the slider to change it not appear, etc?

A Guy
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
The setup doesn’t let me set it over 1000. The slider can move if you slide it with your finger but the values don’t change. Also it has a ding sound when you use the arrows to change it.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,803 Posts

Some are saying it affects all GTs as well, they claim there is a TSB for it. I haven't heard that, nor have I found it.

https://bit.ly/2r8TUAP

A Guy
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Thanks for the information. If there is a service bulletin I wonder why the dealer couldn’t find it? They said there wasn’t an update available lol. I guess I can try going back and letting them know there is a service bulletin. Anybody know what bulletin number or key words they should look up?
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,803 Posts
Hopefully they will answer you there and you can share with us. A Guy
 
1 - 9 of 9 Posts
Top