Dodge Challenger Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1 (Edited)
HEY FoLKS..
After i installed my drop in k &n filter im noticing a lot of hesitaion on accelaration now.,,,i dont feel like i was feeling that with the stock filter but now,,,im stomping it to get a good reaction and to buld up speed,,any ideas??thanx....:werd:
 

·
Banned
Joined
·
1,340 Posts
have you tried the throttle calibration yet? just turn the key to on position, do not crank and press gas peddle slowly and let off slowly?
 

·
Premium Member
Joined
·
3,546 Posts
Just pull it out for a minute or so and reinstall it. Its in the under hood fuse box. If you pull the battery cable off it will do the same thing but you have to reset things like your clock and that fuse just does away with the driving habit memory.
 

·
Registered
Joined
·
585 Posts
my cross to bare is being a wise arse, sorry......you did take the filter out of the plastic bag? gimme three steps mister............
 

·
Registered
Joined
·
585 Posts
HEY FoLKS..
After i installed my drop in k &n filter im noticing a lot of hesitaion on accelaration now.,,,i dont feel like i was feeling that with the stock filter but now,,,im stomping it to get a good reaction and to buld up speed,,any ideas??thanx....:werd:
sounds like it could be starving for air. Those freaking bags I have to jab em with a ice pik....kevlar or summit. I dropped a K&N in mine and it just took in a deep breathe and thanked me
 

·
Premium Member
Joined
·
3,546 Posts
OK sorry I didn't get it. Before I got my CAI I put a K&N drop in filter in and didn't have a problem but just thought maybe it thought it was to lean and that the PCM was over reacting. That's why I suggested the fuse pull. No air flow like you said would cause a problem. My K&N filter wasn't in a bag just in the box. I feel ripped off. For $55 I should have got a bag too.
 

·
Registered
Joined
·
585 Posts
OK sorry I didn't get it. Before I got my CAI I put a K&N drop in filter in and didn't have a problem but just thought maybe it thought it was to lean and that the PCM was over reacting. That's why I suggested the fuse pull. No air flow like you said would cause a problem. My K&N filter wasn't in a bag just in the box. I feel ripped off. For $55 I should have got a bag too.
think the #2 fuse pull is a good move too and I really was being smart about the bag....BUT it seems odd for it to act that way so hope he keeps us posted
 

·
Premium Member
Joined
·
3,546 Posts
Me too, After the last time I posted I noticed this was on an SE and I don't think it would be that picky. That would make me think maybe something got knocked loose when changeing it out. I think I'ld put the stock one back in and see what happens.
 
1 - 15 of 15 Posts
Top