Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 14 of 14 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 · (Edited)
I have a 2017 challenger R/T auto. The car runs, but won’t go past 50% throttle. It’s not the tune, we changed the throttle Body’s out, 87,92
we checked the plugs on TB for voltage, same says all good there.
Any help please!!!m
 

·
Registered
Joined
·
2,457 Posts
If you're revving the motor while it is in park or neutral, it won't go past 3000rpms, it's a protective measure so the motor isn't destroyed.

Sent from my SM-G998U using Tapatalk
 

·
Registered
2011 SXT Built in the Canada Plant
Joined
·
2,309 Posts
Did you change the PCM to a Unlocked one BTW? Also did you put a Tune on it afterwards and the Limiter as mentioned, Did you also change your Fuel Pump and Injectors? There is more then just bolting on a SC and say ok its ready to run.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
We did a complete swap. The car runs and drives. The issue is it won’t WOT. It still goes the full Rpm range but on the data logging it won’t go over 50%
yes the ecu is new and tuned after Ihave a very good tuner who ishighly regarded on here. It’s not the tune.
 

·
Registered
2013 R/T
Joined
·
230 Posts
This is close to being normal on mopars. My car scanned with HPTuners pegs @76% but I shift @6k. Your not going to get it to read 100% floored.

Here is a scan played back at half speed. Look at the TPS column. Play it full screen Utube.

It may be something in the tune or sensor. Or a relearn may be needed. I know if I unplug my TB cable with the battery connected, after reconnecting it runs rough abdI have to do a relearn in HPTuners. You can hear it slapping the plate.



 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
We did a relearn on all the Tbs. and no 50% is not normal, 75% yes bc voltage of 3.5 reads the same as the 4.6
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #10 ·
Could you elaborate? I know the max is 5.0 but I’m told 3.5 - 5.0 reads the same for throttle %
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #12 ·
No, I had one before the build. However we had the tuner change some throttle blade positioning and saw an improvement today.
 
1 - 14 of 14 Posts
Top