Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
536 Posts
Discussion Starter #1
I have noticed when I'm driving 13 RT automatic I get a thud sound when accelerating or breaking. I took it to the dealer and they replaces front and rear end links, both motor mount transmission mount and the front stabilizer bars that I have seen fail on the forum. The car has 76k miles. I wouldn't mind the issue but st times Intel like I, being rearmed. What the shop did helped some but it's still there. Also when going over road dots the rear end feels like it wants to sway I, onlyndoing 60 to 65. They say the car is okay. What can I do to get this resolved.
 

·
Registered
2018 Scat Pack SHAKER in Plum Crazy
Joined
·
3,441 Posts
Find a way to recreate the thunk when parked. Then with help, crawl/lay under car holding components until you find the part that jumps with the thunk. Or ask a local shop guy to take a ride with you, say you'll give him $20 just to tell you where it is coming from.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
8,494 Posts
I had a very similar issue with my 2011 Challenger a few years ago (when I still had the car), and I was never able to get it resolved. I resorted to giving several dealership techs rides in the car so I could recreate the noise for them, and while they would agree they could hear it, they could never identify what caused it once they tried to diagnose it on their own.

I had a thread detailing the whole ordeal on here somewhere, but I am unable to find it at the moment. If I find it, I will update this one with a link to it so you can read through it and maybe see if anything is of use in trying to rectify your rear-end clunk.
 
1 - 4 of 4 Posts
Top