Dodge Challenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Hi all,
I recently bought a new challenger Sxt Plus with the Sport package. Around 900 miles there came a slight ticking sound while driving that went away, but now at 1360 miles, it has come back, but louder. When the car is reved in neutral, there is no abnormal noise. However, when put into drive, any rpm above idle will result in a noise (audible inside the cab) that sounds like a muffled ticking/pulsing noise. Any idea as to what it might be?

THANKS!
 

·
Premium Member
2014 100th Annivesary R/T
Joined
·
517 Posts
Its under warranty, take it to the dealer and have them fix it. Now with that said sounds like you something is going on with the drive train. Do you have the sound sitting still with the car in park?

Still suggest taking it to the dealer and have them fix it, the warranty is good for 36k miles!!

-Kenny
 

·
Registered
Joined
·
133 Posts
Discussion Starter #4
Yeah I figured as much... In any case, no the car does not make the noise when in park, only drive. Also, I was under the assumption that the car was under warranty for 100k miles?

Thanks!
 

·
Premium Member
2014 100th Annivesary R/T
Joined
·
517 Posts
Yeah if its not happening sitting still, then its something in your drive train, it could be anything from transmission, rear end, axles, hubs, brakes, this is where you really need to get a mechanic to look at it if you don't have troubleshooting experience, this is something plugging a computer into the car is not going to tell you what's wrong.

Basic warranty is 36k, not sure what you have for extended.

Hope they can identify it quickly and get the problem resolved for you. Good luck!

-Kenny
 

·
Registered
Joined
·
133 Posts
Discussion Starter #6
Thanks alot Kenny. Also while were still on the subject one more question: How bad is redlining a few times at low milage?

Thanks!
 
1 - 6 of 6 Posts
Top