Dodge Challenger Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
Hi all,
I recently bought a new challenger Sxt Plus with the Sport package. Around 900 miles there came a slight ticking sound while driving that went away, but now at 1360 miles, it has come back, but louder. When the car is reved in neutral, there is no abnormal noise. However, when put into drive, any rpm above idle will result in a noise (audible inside the cab) that sounds like a muffled ticking/pulsing noise. Any idea as to what it might be?

THANKS!
 

· Premium Member
2023 Scat Pack R/T T/A *Scheduled for production*
Joined
·
536 Posts
Its under warranty, take it to the dealer and have them fix it. Now with that said sounds like you something is going on with the drive train. Do you have the sound sitting still with the car in park?

Still suggest taking it to the dealer and have them fix it, the warranty is good for 36k miles!!

-Kenny
 

· Premium Member
2023 Scat Pack R/T T/A *Scheduled for production*
Joined
·
536 Posts
Yeah if its not happening sitting still, then its something in your drive train, it could be anything from transmission, rear end, axles, hubs, brakes, this is where you really need to get a mechanic to look at it if you don't have troubleshooting experience, this is something plugging a computer into the car is not going to tell you what's wrong.

Basic warranty is 36k, not sure what you have for extended.

Hope they can identify it quickly and get the problem resolved for you. Good luck!

-Kenny
 

· Registered
Joined
·
2 Posts
Hi all,
I recently bought a new challenger Sxt Plus with the Sport package. Around 900 miles there came a slight ticking sound while driving that went away, but now at 1360 miles, it has come back, but louder. When the car is reved in neutral, there is no abnormal noise. However, when put into drive, any rpm above idle will result in a noise (audible inside the cab) that sounds like a muffled ticking/pulsing noise. Any idea as to what it might be?

THANKS!
I have the same issue in my 2020 Challenger SXT.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top