Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
2010 Challenger R/T
I was having issues with my high speed radiator fan relay. It kept blowing. After some initial checks we determined that the TIPM was at fault. So the journey begins. Do I take it to the dealer and spend anywhere form 800-1200 or do I find a used one on Ebay and do it myself.
I decided to give it a go. I scored a new TIPM from a guy about 15 minutes down the road who specializes in rebuilding and or selling refurbished and new units. ($250.00) So my mechanic and I disconnect everything and swap out the module for the new one. The instructions from the person who sold it to me where to put the car in the run cycle without starting it for 12 seconds and to start the car and run it. He also mentioned that I had to disconnect the battery and leave it tied together overnight. ( I skipped this step) So after the initial startup the gauges lit up with every type of error you can imagine. We simply hooked up an OBD scanner (Diablo) and it had a 24 error codes. We proceeded to turn the car off and clear all the codes. Restarted the car and no codes everything normal and no more blown relay fuses. I hope this will help someone that might have to do this in the future.
 

·
Registered
Joined
·
2 Posts
Did you have to actually program it or anything? I just bought a new one from Dodge cause I couldn't find another 2010 anywhere but my car still won't start?
 

·
Registered
Joined
·
2 Posts
Something has either my security shutting down my car so it wont even crank at all or my ecu/ngc is bad.
 
1 - 4 of 4 Posts
Top