Dodge Challenger Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
1,004 Posts
Discussion Starter #1
(Cut and pasted from different forum). Wow, am I disappointed. Wife and I had a great time except 7 yr old was bored. We made four runs, I had 14s every run, never broke 100. Beat her GT 3 out of 4 times (barely). Next time I'm taking the Predator and trying out the stock tune and others (and datalogging). This was with the latest 9r28 crom. First time was great fun (we'd have stayed all night) but pretty disappointing on the times. Here's the time slips, I'm on the right on all runs (I was car 271). The 1st slip was cut off but I actually won that one even though her times were faster. Things were a little confusing at first but it worked out.

Granted, the GT needs some work too. Good thing is, wife is hooked, she had a blast and doesn't care about the times. She actually mentioned getting a supercharger for her car (unbelievable!).

No wheel hop (I have an auto) may need better tires. Next time I will try harder. I can feel my tires spinning at the launch. Racing is a BLAST! Now I want to get faster, one way or another.

It wasn't real busy so we could run and then get right back up there. It's hard to drive around the water, they spray it everywhere and they seem to expect you to drive through it. Frankly, we were going to drive around it but there wasn't a chance. Also, I have 255/55/18s on the back. I have heard about letting air out (28 psi), don't know the real value. And yes, I spun the tires. I tried it with traction on, off and put it in manual (TC on) and let it shift (three separate times). Didn't seem to matter much. I did try to just barely light the second staging light.

I was using the 9r28 tune, 91 oct, and "12" on the new throttle adjustment, which seems to give you more acceleration with less depression of the accelerator. Maybe a bad idea at the track. The temp gauge was around the 190's (I think) each run. Anyway, I'm gonna bring the Predator next time, try the stock tune and a previous tune from Diablo (9r17e) that seemed to be "interesting" in previous driving. Dunno. Maybe some data logging with the stock tune, maybe to help with getting a custom tune. I absolutely need to get more control during launches, I was pretty pumped and slightly overwhelmed. Definitely need some drag radials.

Also, I learned my 7 yr old just happened to video (with iPhone) the one run where my wife beat me. It's now all over Facebook with how she "owned me". Funny comments from all. See the time slip where left (or 270) was faster. The weight of our cars is a real handicap.

Anyway, let me tell you - that GT is fast! She caught up to me several times - I was lucky to get 3 out of 4. Don't underestimate them. Also found out she wasn't left braking it and upping the rpm's with her right - no wheel spin. Wife hasn't stopped talking about racing last night and was ready to go tonight, but it's raining.

Next week, we've been invited to Camarofest hosted by Camaro5, at Firebird (for those interested racing Camaro's). I will say, we spoke to several people out there for the 1st or 2nd time - new Mustang, Camaro and Corvette owners. Everyone was very nice and humble (and a bit nervous). Of course there were the 10 sec cars too, mostly 60-70s cars.

All: Seriously, get out and try this at least once.

 

·
Registered
Joined
·
1,371 Posts
dude, what was the weather like cause you should have been running waaay better than that...especially with an auto...stock auto R/T's are known to get low 13's when launched correctly and definitely breaking over 100mph! hell, i sucked ass my first trip with my stock 6 speed and broke a hundred a few times, and i did everything wrong from driving through the water box and not spinning the tires (staging with wet tires) and not letting enough air out of the rears to just dropping the clutch and hopping like crazy :)! i'm not saying that to be a *****, but to show you that your car has waaay more potential!

look at what chris1992 or dodgetony(when he had his R/T) was able to do with their auto R/T.
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #3
dude, what was the weather like cause you should have been running waaay better than that...especially with an auto...stock auto R/T's are known to get low 13's when launched correctly and definitely breaking over 100mph! hell, i sucked ass my first trip with my stock 6 speed and broke a hundred a few times, and i did everything wrong from driving through the water box and not spinning the tires (staging with wet tires) and not letting enough air out of the rears to just dropping the clutch and hopping like crazy :)! i'm not saying that to be a *****, but to show you that your car has waaay more potential!

look at what chris1992 or dodgetony(when he had his R/T) was able to do with their auto R/T.
These were the comments from a different forum: I looked up DA for your 6pm run and it was right at 2250 ft and although that isn't negative 1500 like places like ATCO see at times in the year, it isn't completely terrible. Without a doubt though, being 2250 will kill some power. I have noticed roughly a .1 drop in ET for every 1000 ft as an average on both my Challenger and my duster. So some better air, regardless of where it is at, and you will see better times.

Regardless, my 60' times were not very good. I was spinning my wheels quite a bit. R/T's weren't so great either.
 

·
Registered
Joined
·
1,371 Posts
These were the comments from a different forum: I looked up DA for your 6pm run and it was right at 2250 ft and although that isn't negative 1500 like places like ATCO see at times in the year, it isn't completely terrible. Without a doubt though, being 2250 will kill some power. I have noticed roughly a .1 drop in ET for every 1000 ft as an average on both my Challenger and my duster. So some better air, regardless of where it is at, and you will see better times.

Regardless, my 60' times were not very good. I was spinning my wheels quite a bit. R/T's weren't so great either.
hmm...looking at your 60's, they were as bad as mine, but i was still breaking 100 and roughly at the same DA. not sure whats happening...:scratchhead: it could be a number of factors. there are so many variables that can effect the numbers and outcomes...
 

·
Premium Member
Joined
·
3,546 Posts
That really sucks, I was hopeing for 13.8 or so when I go to CF2 in a couple weeks and if your in 14s with more stuff than me I'm not going to be there.
 

·
Registered
Joined
·
1,371 Posts
That really sucks, I was hopeing for 13.8 or so when I go to CF2 in a couple weeks and if your in 14s with more stuff than me I'm not going to be there.
dont fret...there are plenty of stock r/t's in the mid-low 13s. just gotta learn how to finesse 'em a little off the line to get there...
 

·
Registered
Joined
·
427 Posts
My wife also has a 10 Mustang GT Premium & I was surprised how quick it was as I used to beat them with my 08 FWD Grand Prix GXP (LS4 V8). My son ran a [email protected] with the Mustang when it was new. There was a Challenger R/T with a tune that ran a 13.3 that night so these cars seem pretty close.

My wife wants to supercharge her Mustang too. I told her I wear the horsepower in the family. I'm planning on adding nitrous to my SRT8 & maybe an alum 426, built tranny, built rear, ect... It never ends.
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #8
Well, I don't know guys. Next time I will try stock tune and chage some settings on my current predator tune. I had that sucker floored and it just stopped pulling hard at the 90's.
 

·
Registered
Joined
·
248 Posts
All I can say is practice practice practice. Try some good octane booster and put the 93 tune in at the track. I was at speedworld about a month ago and was running consistent 13.6 times on the factory tires. I have a flowmaster system, H&R springs, Mopar cai, and was running the 93 tune.
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #10
All I can say is practice practice practice. Try some good octane booster and put the 93 tune in at the track. I was at speedworld about a month ago and was running consistent 13.6 times on the factory tires. I have a flowmaster system, H&R springs, Mopar cai, and was running the 93 tune.
Right now, I'll do anything to get into the 13s. I'll try it.
 

·
Registered
Joined
·
1,067 Posts
These were the comments from a different forum: I looked up DA for your 6pm run and it was right at 2250 ft and although that isn't negative 1500 like places like ATCO see at times in the year, it isn't completely terrible. Without a doubt though, being 2250 will kill some power. I have noticed roughly a .1 drop in ET for every 1000 ft as an average on both my Challenger and my duster. So some better air, regardless of where it is at, and you will see better times.

Regardless, my 60' times were not very good. I was spinning my wheels quite a bit. R/T's weren't so great either.
The reaction times will get better. Just remember, they have nothing to do with your ET. You can sit there all day after the green and still run a 12 second ET, the clocks don't start till you launch. You need to work on your launch technique. I ended up doing a 2 step process to launch my car. I didn't hold the brake and bring the RPM up, that just made it spin and wiggle around. I went about halfway on the throttle for just about a quick count 1-2, and then floored it. My best 0-60 time was about 5.1 sec. Turning the stability control off just made it spin like crazy. On an asphalt road, with the temp at about 30 degrees, on the OE tires, my car ran a [email protected] something. I'm not at home so I can't look up the numbers. I spun the first run at about 40 MPH, and still ran a 14.0. I had a Gtech meter and I was using the "Torque" app on my cellphone, and they matched ET's almost exactly, but they had a speed difference of almost 2 MPH. In my friend's '09 Challenger, the G-Tech agreed with the clocks at Milan dragway within a couple hundreths and within a couple tenths in MPH. Needless to say, I was very happy with my times. When my Solo catback is installed Tues morning, and my SRT airbox gets put in, I hope it can go a little quicker.

These cars LOVE it cold, so if it's warm or hot out, expect a hit in performance. And if it's over 85 or so, a pretty big one.
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #12
The reaction times will get better. Just remember, they have nothing to do with your ET. You can sit there all day after the green and still run a 12 second ET, the clocks don't start till you launch. You need to work on your launch technique. I ended up doing a 2 step process to launch my car. I didn't hold the brake and bring the RPM up, that just made it spin and wiggle around. I went about halfway on the throttle for just about a quick count 1-2, and then floored it. My best 0-60 time was about 5.1 sec. Turning the stability control off just made it spin like crazy. On an asphalt road, with the temp at about 30 degrees, on the OE tires, my car ran a [email protected] something. I'm not at home so I can't look up the numbers. I spun the first run at about 40 MPH, and still ran a 14.0. I had a Gtech meter and I was using the "Torque" app on my cellphone, and they matched ET's almost exactly, but they had a speed difference of almost 2 MPH. In my friend's '09 Challenger, the G-Tech agreed with the clocks at Milan dragway within a couple hundreths and within a couple tenths in MPH. Needless to say, I was very happy with my times. When my Solo catback is installed Tues morning, and my SRT airbox gets put in, I hope it can go a little quicker.

These cars LOVE it cold, so if it's warm or hot out, expect a hit in performance. And if it's over 85 or so, a pretty big one.
Thanks, I'll try it next weekend. I'm also going to try the stock tune and an earlier tune from DS. My car almost runs like its got a cam it it at idle now with the lastest tune release. Do you use a predator?
 

·
Registered
Joined
·
1,127 Posts
Just enjoy the car for what it is. Stock RT's are not drag racers they are great looking, great riding, heavy cruisers nothing more.
 

·
Registered
2009 Challenger R/T
Joined
·
2,991 Posts
I ran a 13.4 w/a 2.13 60' when I had just the mbrp exhaust on my R/T. That was in 80*F weather as well. Once the cooler weather finally hit us, I threw some M&Hs on the rear and ran a 12.83 w/ a 1.94 60' (40* weather). After a tune it went down to a 12.56 w/ a 1.824 60'. So theres no doubt in my mind that your car has more left in it!
 

·
Premium Member
Joined
·
350 Posts
13.58 ET's

AZ,
I had simiular MOD's only Mopar Cat backs, Mopar CAI, 91 Oct Prediator tune recommended over 93 Oct tune by most on CT. 98 degree day at Mopar Nationals May 10. Lowered F1's to 22#, turned off ESP, slight burnout to clean tires (checkout Avatar pic), staged power braked to 1500 RPM in auto stick, launched when last yellow came on. Car 60ft 2.06 ran 13.58 at 109 mph. Pretty much consistant all day heat and all. Cooled it down between runs with bags of ice on intake. Practice will help. But now you've got the bug!! Watch out speed is a sickness, the only cure is more Mod's and money. I sold a 10.5 sec 60's Mopar and bought my 2010 RT just to drive on the street, went to the track and now look what I've done. LOL good luck. Listen to the other challenger guys you meet at the track. 13.'s are in your near future.
Well, I don't know guys. Next time I will try stock tune and chage some settings on my current predator tune. I had that sucker floored and it just stopped pulling hard at the 90's.
 

·
Premium Member
2013 Calleenger
Joined
·
37 Posts
Firday Night my first 1/4 mile run

CoastalPlainsDragway.Com

Jacksonville, North Carolinas IHRA Drag Racing

2009 Challenger R/T Classic, Silver 5.7L VVT 6 speed Track Pak with a Voliant CAI and Diablosport 93 oct. tune hill assist off traction will be on, I think she launches fine that way. I will see... and post my slips here Saturday.

:redcap: Mid Life my a$$. I am 60 and know what I like to do by now.. Faster women, faster cars, faster Harley's....and more money! :thumbsup:

OK so here it is last runs on top, just kept gettin better, as the whole drag race thing was pinging arround in my brain, (role up the windows...both of them... turn on lights...it was at night...after 5 runs I noticed the track had changed and was getting way too much traction so I turned of the traction...as I shut off the engine to keep it cool as I lined up to run... keep turning of the traction...helmet full face required here too tight...Damn let's race now with a 15 mph head wind best times were

13.6171 @ 102.71 mph
13.6499 @ 102.98 mph
13.7872 @ 101.36 mph
13.8642 @ 102.25 mph
13.8528 @ 96.16 mph
14.1641 @ 92.80 mph
14.2079 @ 100.43 mph
14.2319 @ 101.83 mph
14.3380 @ 101.36 mph
14.3469 @ 99.97 mph

At the start of the race the track was slippery about 500 feet. I needed the traction on. As the track got sticky I started getting wheelhop. I was even trying not to burn out too much traction wheel hop.

Finaly figured to burn out start in the wet... burn clean the tires... worked best I got good launch little spin and a little wheel hop once or twice more.

I had a great time. Used a set of stock tires Goodyears on the back I saved from the originals from factory. If you have not done this yet you need to! :thumbsup: WHAT A BALL !
 

·
Registered
Joined
·
1,067 Posts
Thanks, I'll try it next weekend. I'm also going to try the stock tune and an earlier tune from DS. My car almost runs like its got a cam it it at idle now with the lastest tune release. Do you use a predator?
Nope, only mod is a drop in AFE ProDry S filter.
 
1 - 20 of 32 Posts
Top