Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Hi I have a 2010 challenger rt, recently the tpms symbol came on in my dash , then it shows all four wheels at the same tire pressure and it says TPMS System fault , this is extremly annoying as it also stays on when driving, my tire pressures are all ok, and I haven't changed any wheels or tires. my car is three years old now so this is not covered under warranty. Can I disable this or will this cost me big $$$$$$ Thanks for any help.
 

·
Premium Member
Joined
·
4,364 Posts
Take it to any tire store. They can use a device that can read the fault code and tell you what is wrong. If one of the sensors is bad it will cost you about $100.

You can thank the Ford Explorer Firestone tire issue for these things.

I was told there are batteries in the TPMS and within 5-10 years the batteries die and they will need replaced... not the battery but the entire TPMS.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
Thanks man I will have it checked first thing in the spring when I take her out of storage again, I hope its something simple like a senser.
 

·
Registered
Joined
·
81 Posts
If the tire store will agree to it, you can buy TPMS on ebay for about $50-$60 for a set of 4. The ones in my 2013 RTC are P/N 56029398AB (black stem).
 

·
Registered
Joined
·
104 Posts
TPMS

Had same thing with my Heritage 20's as soon as it got cold out {tps malfunction /flashing light} was told common issue with dodge.I think moisture wreaks havoc with these systems...put nitrogen in & it stopped completely-never happened again ..worth a try!:shrug03:
 

·
Premium Member
Joined
·
2,993 Posts
Did you add any aftermarket electronics? Trinity tuner, cell phone charger, 12v to USB charger, aftermarket gauges, HIDs, anything?

These can all interfere with the TPMS signal.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #7
Tpms system fault

Hi folks thanks for the replys, my tires are nitrogen filled since i purchased the car but i did add a no esp mod and a diablo intune this past summer, i hope neither one of these mods are to blame or i guess i will have to live with the tpms system fault.
 
1 - 7 of 7 Posts
Top