Dodge Challenger Forum banner

1 - 6 of 6 Posts

·
Banned
Joined
·
552 Posts
Discussion Starter #1
So my traction control light, abs and squiggly lines lights are on. I was getting speed sensor code so I thought that was it. I got rid of the code but lights remain on.
I do know that if you don't have the right buttons in the dash that will also trip the lights. Since I am rebuilding theft recovery I may have the wrong buttons. It's a 2010 srt8 auto.

Im open to suggestion.
 

·
Registered
Joined
·
719 Posts
So my traction control light, abs and squiggly lines lights are on. I was getting speed sensor code so I thought that was it. I got rid of the code but lights remain on.
I do know that if you don't have the right buttons in the dash that will also trip the lights. Since I am rebuilding theft recovery I may have the wrong buttons. It's a 2010 srt8 auto.

Im open to suggestion.
The buttons are the same from one car to another.

Sounds like you have something disconnected in the ABS/ESP system or a bad sensor, or a bad control module.

Mike
 

·
Banned
Joined
·
552 Posts
Discussion Starter #3
The buttons are the same from one car to another.

Sounds like you have something disconnected in the ABS/ESP system or a bad sensor, or a bad control module.

Mike
I can tell you this from personal experience.
I also have an 06 Daytona and when I bought my nav system from an 07 srt8 charger the guy left the buttons in the trim plate so I just plugged it up. My lights came on. I swapped the switch / buttons and the problem went away.
I've checked all connections at the abs module and wheel sensors.
I also have 2 other sets of buttons from other cars and they don't share same part numbers.
 

·
Registered
Joined
·
627 Posts
Here is part number just in case. It's for 2009-10 with electronic stability control.

68025931AA $47.45 retail



Sent from AutoGuide.com Free App
 

·
Banned
Joined
·
552 Posts
Discussion Starter #6
Well I def have the right switch. No codes. Nothing feels wrong with the brakes. I've never got into a car too much with abs / traction control. Safe to assume that the traction control is triggered by the wheel sensors? If no codes and the brakes don't feel strange it makes me think its an electrical short of some sort.
 
1 - 6 of 6 Posts
Top