Dodge Challenger Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello , I have a 2015 SRT 392 , after grazing a curb I recently replaced a bent left rear lateral toe link , I noticed that my traction control light stays on all the time.
The major problem is that the rear of the car sways back and fourth so bad especially under acceleration , rides really rough like I’m riding in old school mini truck , suspension air ride or whatever is not working , I replaced the left rear wheel speed sensor and problem is still there , anyone have some input on this issue would be much appreciated ??
 

·
Premium Member
Joined
·
898 Posts
I recently replaced a bent left rear lateral toe link....... the rear of the car sways back and fourth so bad especially under acceleration , rides really rough like I’m riding in old school mini truck , suspension air ride or whatever is not working , I replaced the left rear wheel speed sensor and problem is still there...
Welcome to the forum. It sounds to me like you have a problem that is more than a sensor. You state you "grazed" a curb but the way you make it sound is that the whole rear end is out of whack.

My guess is that you have some good sized alignment issues on your rear end and the speed sensors (which are very sensitive) are picking up the variance in your rear wheel speed, hence throwing a code.

I'm suggesting you take it to the dealer (yes and pay stupid money) and have them put your car on a legit alignment machine. You may have more out of alignment than you think.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I agree with you on that .... with that being said , do you think it would cause my electric air ride (whatever you call it ) to absolutely no longer work as well , because it feels like I’m riding on blocks instead of shocks . I can tell that isn’t working any longer either ?
 

·
Super Moderator
Joined
·
17,434 Posts
you may have bent the rod in the shock - and it may be binding. I suspect that an impact enough to bend one link may have bent other components.

your SRT 392 doesn't have air ride. It has adjustable damping shocks (all four corners)

as far as the traction control, it might be an issue with the tone ring on that corner - it might be out of position and the sensor can't get a consistent signal for the system
 

·
Registered
Joined
·
1,923 Posts
You would be amazed at how many systems are in a car these days.

horizontal axis sensors
Yaw rate sensors

the list goes on.

It’s not only about replacing bent parts anymore. There could be resets and calibrations needed.

I would have a professional look at it.
 

·
Premium Member
Joined
·
898 Posts
CDS392,

The more you write the more this car sounds pretty messed up. Take her to a professional and get ready to pull out the card. The grazing the curb it seems more than you think.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top