Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey Guys i am new here but not new to cars, i need some help and i have scoured the internet for days to see if anyone else has had the issue i have but no resolve. NOT CHALLENGER but seems this forum has alot of insight and help

2008 300c srt8 Procharged fully built trans 62K og miles

so just bought the car and after a couple of days started having shifting issues at first i would try and go into autostick and couldnt get it to go past 2nd gear sitting still or driving and yesterday i took it out for a spin and got it into auto stick and got on it a lil bit and NO UPSHIFT then tried to go back into drive wouldnt happen so went to neutral and back to D and i assume it went into limp mode in 2nd gear but i have a 3300 stall so didnt want to go anywhere. I got it back to the house and hooked up my code reader and 0 codes pending or set, checked fluid still cherry red and new smelling (i have a benz dipstick)

ANY HELP WOULD BE GREATLY APPRECIATED
 

·
Registered
Joined
·
1,234 Posts
Where you at? Is there a performance shop near by? Wondering if the stall converter was upgraded. Could be something a good in-house tuner could fix too.
 

·
Registered
Joined
·
1,797 Posts
If it was me I'd try to find out if there was a shift kit installed in the trans? more then likely the line pressure was raised to high (this can be achieved either mechanically or electrically) this can result in the symptoms you're experiencing...raising line pressure to high causes all kinds of weird things to happen including but not limited to limp mode..just a few things to keep in mind, good luck
 
1 - 4 of 4 Posts
Top