Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello Everyone,

Apologies if a similar topic has been posted elsewhere. I did some searching and could not find anyone with my issue.

I purchased a new trinity, and I am having issues flashing my 100% stock 2014 Challenger RT Classic. I installed all the software on my pc, updated as the instructions told me to, then started the process to identify and calibrate my tuner to my car. Here is whats happening.

* With ignition on and the trinity connected, the device detects I'm running *AH and need to downgrade to *AD
* Trinity starts downgrade, gets to 100% , then asks me to "turn key off"
* I turn the key off, then Trinity asks me to wait 10 seconds.
* Trinity waits 10 seconds, then asks me to turn key on.
* Car is 100% dead. No battery/accessory no ignition/run, no tuning over.. nothing. However headlights work, keyfob will open trunk. That's about it.
* The only way I can recover is to disconnect the battery and reconnect and then the car is usable again.
* After recovery Trinity display says "Update did not finish, Calibration update via DSDL was completed successfully. press center key to update vehicle calibration"

I tried this a second time, and got the same result. I thought that maybe the update from my PC was incomplete is some way so when I connect the device back to my PC it seems to be in a bootloop locked at the please wait screen.

Here is the Rub, I have reached out to Diablosport support 4 seperate times and each time once we talk about the car locking up their communications with me stop. Did i do something wrong?
 

Attachments

·
Registered
2015 Dodge Challenger R/T Scat Pack
Joined
·
1,189 Posts
Maybe you could get with one of the tuner guys like Sean at Hemifever Tuning. He might be able to help you out and then sell you a better tune than what comes loaded on the Trinity anyway. He's been helpful to me in the past with issues.

Pretty sad that Diablosport can't seem to help you out. Have you tried reverting the Trinity back to an older version? Or have you tried the latest update on their website? Maybe something is just stuck in the tuner and updating it or reverting back will free it up. Or maybe that particular tuner is defective. Would be neat if you could borrow someone else's and try it out and see if you get the same result or not. Then you'd know if it was the tuner or something with the car.
 

·
Premium Member
Joined
·
1,454 Posts
I had issues with mine a few year and I ended up just not turning the key off when asked and it all worked. Wait the required amount of time, just dont cycle the key and see if that helps.
 

·
Registered
Joined
·
850 Posts
I feel your pain. I had a problem with my Trinity a couple of years ago and after 82 emails with Diablo and them turning their computer off and going home for the day without even telling me they were quitting, I returned the tuner/PCM. Good luck.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
Thank you everyone, this has been very educational.

So after all this happened with the car, now when the tuner is powered up its stuck on the screen "update did not finish" (see attached pic from original post). Short of taking it apart and trying to hard reset the tuner somehow its basically a paperweight. I cant get any of my computers to recognize the damn thing to try and upgrade/downgrade. As a last ditch effort I will try the diablosport Forums. "Powerteq Customer Service Manager" Mike Litsch was one of the people I was corresponding with before communications stopped.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
So it looks like back in 2012 there was a bug that affected 2011-2014 Challenger owners:

"It seems there is an issue when loading the tunes and using the push button start. To avoid any issues, it is highly recommended that you simply pop the button out and use the key during the tune loading process. If you wind up with a non responsive starter button after loading the tune, simply pop it out, stick the key in, and all will be well. We should have a fix for this asap, and will release a new update as soon as it is ready."

Fast forward to 2017 and this is still a problem in the latest updates. Reached out on the Diablo Forums to see if there was any way to reset the tuner so I can try flashing again.

Thanks again everyone.
 

·
Registered
Joined
·
2,104 Posts
In my 2013 R/T I always pop out the push start button and use the key. It works, however every once in a great while the tuner won't recognize that I turned the key to off and it hangs. So I have to reboot the tuner and then it has to reload the tune again, then the car is tuned properly. Kind of a pain, and it's nerve-racking as hell. I have read a little too many threads over on the DiabloSport forums about people bricking their cars into giant 4200 pound paper weights.

Also how come when it's loading a tune all the damn headlights and brake lights come on and stay on?? Talk about hoping my battery does not take a dump in the middle of a tune!!
 

·
Registered
Joined
·
850 Posts
So it looks like back in 2012 there was a bug that affected 2011-2014 Challenger owners:

"It seems there is an issue when loading the tunes and using the push button start. To avoid any issues, it is highly recommended that you simply pop the button out and use the key during the tune loading process. If you wind up with a non responsive starter button after loading the tune, simply pop it out, stick the key in, and all will be well. We should have a fix for this asap, and will release a new update as soon as it is ready."

Fast forward to 2017 and this is still a problem in the latest updates. Reached out on the Diablo Forums to see if there was any way to reset the tuner so I can try flashing again.

Thanks again everyone.
Did you ever get your car running again?
 
1 - 9 of 9 Posts
Top