Dodge Challenger Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have an 09 Challenger SRT8 i have been working on for several years. Modern Muscle did the engine build and its Procharged. I am at 772 RWHP now. Issue I have is the custom tune runs perfect for about a month then it I start to get hesitation issues at low end and then a code in relation to throttle body sensor not playing with position sensor. I have had this issue for a few years and I'm getting frustrated. I have gone through a few "well known"tuners here in S. FL. . The tune now is the best it has ever been but in a month it will throw a code and put me on the side of the road. Modern muscle said they have come across this in rare cases and don't have a solution "they have been great". I'm the guy with the 1 in a million issue. I know i can't be the only one out there so any help i can pass on to my tuner would be great. Pls experienced folks with this issue. I'm the information passer not the tech guy obviously. I really am looking for someone who has had or knows of someone who has had and fixed this problem. When the issue arises it never seems to effect the cars high end. It just makes it very difficult to drive in the city "6 speed".

What the computer seems to do is take a good tune, then try to learn whats going on and then it messes up my tune. I'm running 10lbs of boost, nothing is stock except me. We talked about a vacuum assist for the throttle body but I'm unable to find anything like that. I'm hoping to find someone who has found a solution to the same type of issue. Thanks!
 

·
Registered
Joined
·
3,501 Posts
I have a 09 with a 6 speed and while I don’t have that issue I get a occasional idle hang. I have spent 2500 in tunes. I have a built motor and magnuson. After talking to several people the consensus is the older computers in our cars ( mainly software versions ) have some bugs. I never had the issue till I took the car in yrs ago before I didn’t all the work and the dealer did a update.
Ever since then it has this idle hang. If I turn the a/c on it is worse

So you are not alone. I think it is a by product of older software that is not fixable


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3 (Edited)
That was also something we have talked about. I have just a few bucks in this car and I'm not giving up. I'm wondering if we replace the computer with a newer version. It doesn't make sense how the tune runs great for awhile then it all changes one day. The guy I'm using now runs Olympic Motorsports. He has done amazing tune work but the Ghost of Christmas past keeps kicking our butts.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
No and no. Ill try to list specks tomorrow. Other issue is keeping it straight on the track. Need more time getting use to slicks Also may need frame brace but main issue is figuring out the tune computer issue
 

·
Registered
2015 SRT 392
Joined
·
2,713 Posts
I'm Sorry to hear about your problem!

Which software did your tuner use when he tuned her?

Can you Please tell us the code number that is being thrown?
 

·
Registered
Joined
·
3,501 Posts
It’s isn’t throwing a code. It is a byproduct of older pcm


Let me know if you end up switching the pcm I am curious if that fixes if


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Dino on the car. Found out by removing the Procharger intake screen it gave me almost 50 RWHP more. I only take this off at the track.
 

Attachments

·
Registered
Joined
·
19 Posts
Discussion Starter #9 (Edited)
test my posting will delete. going off my invoices so if something below doesn't make sense let me know.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
Anyone else have this type of issue with a possible fix. As for the pcm it’s linked to the car so that doesn’t seem to be an option unless I want a stand alone computer that just runs the engine which is about 4K. Other option is to just keep resetting the tune when the computer starts to adjust things. Adaptive computer isn’t nice to work with.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
Going to work more with the tuner. If we find the fix I’ll post here so others can get help down this long road. Other final option is getting a stand alone computer to just control the engine which is will fix the problem if we can’t get The tune to stay on the current computer.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #13
The tune is great at first. It’s a few select model years it seems to effect. Adaptive learning is the issue. As for tuners I’ve gone through a few very highly recommended guys. I’ve spent a considerable amount of money on tuners. Unless they can tell me they know of my issue and can fix it I’m sticking with the guy I have. Thanks
 

·
Registered
2016 Jazz Blue A8 Scat
Joined
·
694 Posts
So is the issue that over time it is changing the LTFT to pull fuel out on throttle tip-in, making it lean under initial throttle application?
 

·
Registered
Joined
·
3,501 Posts
like he said it is adaptives.. i have a 09.. i don't have the LAG but i have throttle hang ( clutch car ).. mike at ost.. hemituner, ect ect have tried to fix it.. nobody has.. i got 2500.00 in tunes from everyone under the sun.. NOBODY has fixed it.. it must have something to do with the older ecu.. i suppose i could get another computer have everything swapped over and spend another 12-1500 doing that but to go thru all that and have the same thing happen i would be HOT!
 

·
Registered
Joined
·
71 Posts
like he said it is adaptives.. i have a 09.. i don't have the LAG but i have throttle hang ( clutch car ).. mike at ost.. hemituner, ect ect have tried to fix it.. nobody has.. i got 2500.00 in tunes from everyone under the sun.. NOBODY has fixed it.. it must have something to do with the older ecu.. i suppose i could get another computer have everything swapped over and spend another 12-1500 doing that but to go thru all that and have the same thing happen i would be HOT!

I have a 2010 and when I installed my FRI/Scud cam, I initially had the "hanging ídle" u mentioned; but after
3 revisions by Mike/OST, this was eventually eliminated. For automatics, this was easily fixed by getting a higher stall TC; but for 6-speeds like ours, tune revisions eventually fixed said anomalies.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #17
I’m in the same boat on spending a lot on tunes and don’t want to go to a stand alone computer yet. But with the money I have in the car already it may be my only option. My tuner guy has not given up yet so I will post what finally resolves my issue . Both guys who are helping me,one who has been doing Mopar’s for over 30 years and runs drag cars and my tuner both say a stand alone computer will resolve the issue. But we are not going there yet. Been on and off trying to resolve this for several years now. Again. The tune is awesome but changes after a month or so and will start throwing codes and put me on the side of the road. The motor is heavily modified and pro charged. Thanks for all the input. What I might do is have my tuner call mike
 

·
Registered
Joined
·
19 Posts
Discussion Starter #18
So is the issue that over time it is changing the LTFT to pull fuel out on throttle tip-in, making it lean under initial throttle application?
Yes basically. It will throw a throttle position sensor code or related code and put me on the side of the road. after I clear the code the issue will get worse and worse but I can drive it home. The car will become very difficult to drive in town, I either stall or smoke the tires or clutch. WOT stays good. Prior to the code the car is pretty civil and easy to drive in stop and go traffic.
 
1 - 18 of 18 Posts
Top