Dodge Challenger Forum banner

1 - 20 of 92 Posts

·
Premium Member
Joined
·
667 Posts
Discussion Starter #1
Reading the thread about the sport mode software bug today, it was posted that the latest uconnect update, 17.11.07 is now downloadable from www.driveuconnect.com. Before this, it was only an over-the-air update, and you could only install it if it was offered from the cellular system.


When you go to the uconnect website, have your vin ready, and know which software version is currently on your car. (controls>settings>system information) I just took a picture with my phone. In my case, a 2015 sxt plus, auto, it said I had two updates available, since I already had the 1st installed, I just downloaded the 2nd, the 17.11.07 version.

I downloaded the update to my computer, it's a compressed file, with windows 10, just hit the extract button on the folder and specify where you want the files. Uconnect wants you to use a totally empty usb, 4 gigs minimum.


On the download page, there is a link to installation instructions, which is quite different from the over-the-air updates. I printed the instructions and took them, my ipad (for solitaire) and a snack out to the car. The download instruction specifically state to start the car, so I kept it running through the whole process. I followed them exactly, and it took just short of an hour. It might have taken less time, I used an old usb stick, if you use a usb 3.0 maybe it would go faster.
The update seems to work perfectly, the "birching betty" voice, sounds more like, "Sexy Betty", but my wife still calls it, "annoying". The "sport mode" button and menus seem to work fine. Now, since I have the latest update, I can update the navigation maps. Good luck!!!
 

·
Registered
Joined
·
80 Posts
Update

Is this something I can do to my 2012? Would this fix the problem/issue we are having with having our sport mode being taken away from us?
 

·
Premium Member
Joined
·
667 Posts
Discussion Starter #3
Is this something I can do to my 2012? Would this fix the problem/issue we are having with having our sport mode being taken away from us?

No, this update is for the 8.4 inch screen uconnect radios. Which, for the Challenger, is on 2015 and up only. I've never heard of the pre-2015 mygig radios having a sport mode problem.....


As far as my car, 2015 sxt plus, auto, sport mode works fine with this new update.


Scott
 

·
Registered
Joined
·
153 Posts
Good to know I wonder if this new update is offers anything for the 17 and up models. I think the issue was with 16 and below models. 17 and up did not have the sport mode software issue, at least I myself didnt.
 

·
Premium Member
Joined
·
667 Posts
Discussion Starter #6
Just in case a newbie sees this thread and decides to update.....beware 2015 6 speed manuals seem to lose sport mode after the upgrade.
It would be hard for me to believe that uconnect would put out the download, if the sport mode problem hasn't been fixed, BUT you're right, I would be very cautious if I had a manual. They did keep pushing out the over-the-air update, even though people were complaining.

Here is the link to the thread about the sport mode problem: http://www.challengertalk.com/forums/f188/sport-mode-not-working-after-software-upgrade-587722/
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
It would be hard for me to believe that uconnect would put out the download, if the sport mode problem hasn't been fixed, BUT you're right, I would be very cautious if I had a manual. They did keep pushing out the over-the-air update, even though people were complaining.

Here is the link to the thread about the sport mode problem: http://www.challengertalk.com/forums/f188/sport-mode-not-working-after-software-upgrade-587722/
Doubt the online download has the fix as the revision has not changed.
 

·
Super Moderator
Joined
·
16,209 Posts
Just in case a newbie sees this thread and decides to update.....beware 2015 6 speed manuals seem to lose sport mode after the upgrade.
This issue also affects 2016 M6 as well - my Scat Pack Shaker.

I'm sending video to tech support about this to elaborate on how its doing it.
-Engine drops out of Sport mode when Sport button is activated
-Sport setting for Engine does not stay set when switching Perf. Pages to other screen displays.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,635 Posts
And Hal did indeed induce that with this USB download, so it is apparently not a fixed version. A Guy
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
Why can't the problem be, sport mode is ALWAYS on and cannot be turned of? Having an 5.7 RT+ the 2 buttons I hit every time I start the car are traction control and sport mode (that is after I hit accept on the uconnect screen). I thought sport mode (at least on the RTs without STP) just bumped the throttle rate and if so, could it not be tuned with a diablo to be permanent?
 

·
Super Moderator
Joined
·
16,209 Posts
Why can't the problem be, sport mode is ALWAYS on and cannot be turned of? Having an 5.7 RT+ the 2 buttons I hit every time I start the car are traction control and sport mode (that is after I hit accept on the uconnect screen). I thought sport mode (at least on the RTs without STP) just bumped the throttle rate and if so, could it not be tuned with a diablo to be permanent?
Sport mode on non-STP R/Ts would modify the throttle response and the A8 shift programs (holds each gear longer before upshift). This was similar to the '14 and earlier R/Ts as well.

If you use the DiabloSport tuner, you can modify the throttle response, which has variable % rates. Don't know if there's part-throttle settings for A8 that can be modified.
The shift point settings in DS are generally for WOT operation and doesn't affect part throttle / light load cruise - unless they've changed that.

The issue may be - I've driven an A8 Scat Pack is the throttle is pretty touchy in Sport mode - so much, that in stop/go traffic (or slick roads) it's not the best choice. Driving on streets that are 25-30 mph in traffic with that isn't a great combination.
-for someone (spouse for example) isn't used to the car as much, there's a big difference in how much pedal travel in Normal vs. Sport.

If I'm in town driving (M6), I'd rather not have that much response. In more open areas, its great. The first part of the drive I put in Sport (in town), I have to adjust my approach since you get a roar of throttle taking off in first until I've acclimated to it.
 
  • Like
Reactions: ChallyTatum

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
I keep forgetting about the A8s. I have the M6 maggie and without sport mode it is too unresponsive for my taste but in the rain it does get squirrel. That is the only time I leave traction control on. The wife won't drive the car anymore with the barton shifter...says it is too much work...oh well, more seat time for me.

Did you contact Dodgecares about your issue and if so, does it look like they may have a resolution?
 

·
Super Moderator
Joined
·
16,209 Posts
I keep forgetting about the A8s. I have the M6 maggie and without sport mode it is too unresponsive for my taste but in the rain it does get squirrel. That is the only time I leave traction control on. The wife won't drive the car anymore with the barton shifter...says it is too much work...oh well, more seat time for me.

Did you contact Dodgecares about your issue and if so, does it look like they may have a resolution?
I did hear from them. Made a video demonstrating what is taking place - if I can get it to go through (its 22MB in lower res and compressed) via email is the challenger now.

Drove the car today - Sport Mode for Engine has no effect, even if you get the indicator "on" in screen.

Once you move to another screen or put Sport button on, it drops it as an indication. Steering and Traction control work as normally would.
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
I did hear from them. Made a video demonstrating what is taking place - if I can get it to go through (its 22MB in lower res and compressed) via email is the challenger now.

Drove the car today - Sport Mode for Engine has no effect, even if you get the indicator "on" in screen.

Once you move to another screen or put Sport button on, it drops it as an indication. Steering and Traction control work as normally would.
You can try posting it on Vimeo (free-basic users get 500mb per week).
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,635 Posts
I did hear from them. Made a video demonstrating what is taking place - if I can get it to go through (its 22MB in lower res and compressed) via email is the challenger now.

Drove the car today - Sport Mode for Engine has no effect, even if you get the indicator "on" in screen.

Once you move to another screen or put Sport button on, it drops it as an indication. Steering and Traction control work as normally would.
Do you have OneDrive, Drop Box, etc? Upload it and send a link. Or a site like

Too Big To Email - Send large files up to 2gb for FREE!

A Guy
 

·
Super Moderator
Joined
·
16,209 Posts
my thoughts are - they created this problem. Why do I have to go through extraordinary steps...

Just fix the damn update!
 

·
Super Moderator
Joined
·
16,209 Posts
Word of advice:

Do not accept the software downloads - the group at FCA keeps demonstrating that they don't test what they push out for software updates.

When you have a problem, you're pretty much on your own and you're going to have to do the work for them...

We now have a new example of Inept [insert picture of FCA software programmers]
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,846 Posts
Word of advice:

Do not accept the software downloads - the group at FCA keeps demonstrating that they don't test what they push out for software updates.

When you have a problem, you're pretty much on your own and you're going to have to do the work for them...

We now have a new example of Inept [insert picture of FCA software programmers]
Too bad you cannot downgrade the firmware.
 

·
Super Moderator
Joined
·
16,209 Posts
Too bad you cannot downgrade the firmware.
It would do that in a minute. I'd rather take mine back to the original 15.xx.xx that it was built with.

The 16.33.29 version had bugs in it as well, but not as serious as this 17.11.07 crap they pushed out.

Then in recent times the '17s had the issue of the Auto-Comfort settings missing from the uConnect pages...it proves that they do cursory reviews, but don't test in-depth.
-these were the new Panasonic units that replaced the former Harmon units used in '15/'16
 

·
Registered
Joined
·
1,028 Posts
Dammit. I found this thread AFTER I upgraded my 2015 SP manual to version 17. The process was sketchy too. I ran into all sorts of issues along the way but finally got the software to install. Does anyone know if turning off all the nannies works in version 17?
 
1 - 20 of 92 Posts
Top