Dodge Challenger Forum banner

1 - 20 of 69 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Looks like my radio just keeps resetting and cannot connect to uconnect services. I call Dodge and get the "this seems to be a nationwide problem...we don't know when it will be fixed."

Call my dealer he says it's been a problem since last night and he is a frustrated as I am. Said he has had customers calling in all day and Dodge is no help.

Amazing. A 40K plus car and the radio is a brick with no fix???????

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
28 Posts
I had a problem with my Bluetooth not working the other day, but it was all good the next morning???
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I had a problem with my Bluetooth not working the other day, but it was all good the next morning???
My radio was fine. Went to lunch, came back out .....endless reset loop. Called dodge. They said it's a nationwide problems on some models. They have no fix for it.

Sent from my SM-N950U using Tapatalk
 

·
Premium Member
2016 SRT
Joined
·
458 Posts
What year and what model of UConnect?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
What year and what model of UConnect?
2018 Challenger. 8.4 screen, with Navigation. System is still down. Spoke to Dodge again. They keep saying it's a problem that began last night but they have no fix.

Going to the dealer and request a new radio.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
168 Posts
Just had the unit in my 17 GT start the reset loop. About once every minute and 20 seconds it reboots


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
261 Posts
Sounds like a uconnect problem. Pull the wire for that and you should be able to use the radio until they get it fixed. I think it is the blue plug. Not sure but if you disconnect the cell service you might be able to use the radio.
 

·
Registered
Joined
·
194 Posts
2018 Challenger. 8.4 screen, with Navigation. System is still down. Spoke to Dodge again. They keep saying it's a problem that began last night but they have no fix.

Going to the dealer and request a new radio.

Sent from my SM-N950U using Tapatalk
Different problem than mine (it would not shut off), but two days after I picked it up, the Uconnect started having problems. Dealership said the whole unit had to be replaced. It took 17 days, many phone calls and the involvement of two area managers to get the unit replaced.

I'm afraid to go start the car now after reading about this problem.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #11
Any updates this AM?
I am pensive about starting my car.
Haven't started her up. I'm concerned as well. Now I'm getting two answers from Dodge. One Rep says there is a problem, another says nothing is wrong. At least get your stories straight. The last rep I spoke to said that anyone who could work on a Uconnect problem is off for the weekend so it would be a few days or more on the escalation.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
194 Posts
Mine worked this morning, the entire unit was replaced 12/20/17 if that helps.
 

·
Premium Member
2016 SRT
Joined
·
458 Posts
Drove mine into downtown last night. No issue as described but there was spotty signal issues. Mines 2016 so I wonder if it’s just 17 and 18’s. There are significant differences in software between them.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #16
Drove mine into downtown last night. No issue as described but there was spotty signal issues. Mines 2016 so I wonder if it’s just 17 and 18’s. There are significant differences in software between them.
Could be. Just started mine. Resets every 30 seconds.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #17
Could be. Just started mine. Resets every 30 seconds.

Sent from my SM-N950U using Tapatalk
Just spoke to uconnect support, they say they believe the signal from sirius/XM guardian is causing the problem. He said it affect many cars a few months ago. They will start working on it tomorrow, but it may take days to solve.

Sent from my SM-N950U using Tapatalk
 

·
Registered
2018 Challenger GT
Joined
·
3 Posts
I'm having the same issue with my 2018 Challenger GT. Called Dodge, same reply you got. Went to the dealer and talked to the guy who sold me the car and his boss. I guess they are making a new update to be pushed today. All the cars at the dealership, his and his boss all have the same issue. Tried it this morning. Still reboots every 20-30 seconds. Which makes driving a bit of annoyance. Luckily its not killing the battery so that's good.
 

·
Premium Member
Joined
·
1,642 Posts
Haven't started her up. I'm concerned as well. Now I'm getting two answers from Dodge. One Rep says there is a problem, another says nothing is wrong. At least get your stories straight. The last rep I spoke to said that anyone who could work on a Uconnect problem is off for the weekend so it would be a few days or more on the escalation.

Sent from my SM-N950U using Tapatalk

Hello blacklaw89 and anyone else experiencing the concern with the radios rebooting,
We are aware of this concern, and regret to hear that some of you have been provided with conflicting information. This is being looked into further. If you have not already called into our customer call centers or sent us a private message, please send as a private message with your VIN, current mileage and additional details.
Thank you,
Julie
Dodge Social Care Specialist
 

·
Registered
Joined
·
24 Posts
Discussion Starter #20 (Edited)
Spoke to the dealership today. May takes weeks until fixed

The bigger issue is that when it resets there goes the backup camera. I would advise everyone with this problem to not rely on the backup camera until fixed.
 
1 - 20 of 69 Posts
Top