Dodge Challenger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter #1
Hello to all, I just got off the phone with Uconnect to help with some minor things with my Uconnect. I started asking questions about the new Uconnect system that’s on the 2018 models and inquiring about purchasing one because it had the Apple car play feature that I REALLY want!!! She advised me that the new 2018 Uconnect model will NOT work in 2017 or below models because it has something on it older models do not have. She also advised me that they are working on an update to have the Apple CarPlay on all 2015-2017 8.4 models. Just thought I would keep you all informed.


Sent from my iPhone using Tapatalk
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
18,564 Posts
It would be nice for those that want it, but an agent on the phone? Not always a fount of knowledge :)

A Guy
 
  • Like
Reactions: Frank Julian

·
Registered
Joined
·
274 Posts
Discussion Starter #3
It would be nice for those that want it, but an agent on the phone? Not always a fount of knowledge :)

A Guy


Lol I know. But I would LOVEEEEE to have Apple CarPlay. She said they’re trying to keep up with their competitors (GM)


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
20 Posts
I'm not totally impressed. Just got my 18 w/7" display. Doesn't have Sirius, not even HD tuner. Just AM/FM, and gets weak signal even on local stations for some reason. My android connected by wire cuts out and locks up. If I choose a song on Amazon music app, it plays another. So if the 18 is an upgrade, I'd hate to see what was its predecessor.
 

·
Registered
Joined
·
5 Posts
Uconnect update from 17.11.07 to 17.11.0743

So I have a 2015 challenger r/t scatpack with the 8.4 RA4 system sound group 2 9 speakers + 1 8” subwoofer in the rear deck. I recently tried updating to the newest Uconnect version via usb stick and it goes through all the update procedures fine. However at the end of this update it seems that it doesn’t actually update and still says “ update from 17.11.07 to 17.11.0743” yes/no”. Did it update and it is just abbreviated or did it not update? Anyone that has gone through this similar issue your advice would be of great assistance! Thank you!
 

·
Premium Member
Joined
·
2,425 Posts
I deleted my response after thinking about it more.

At the end, it should have asked you if you want to update to the exact version you installed, then you would say "no". I have a 8.4 RA3 radio, but I think they would be the same. My latest update was 17.43.01

I wish I could be of more help to you.
 

·
Registered
Joined
·
5 Posts
I deleted my response after thinking about it more.

At the end, it should have asked you if you want to update to the exact version you installed, then you would say "no". I have a 8.4 RA3 radio, but I think they would be the same. My latest update was 17.43.01

I wish I could be of more help to you.
That does help! And I believe it is RA3 but when You updated yours did it say “do you want upgrade from 17.11... to 17.43.01 and you selected yes , am I reading that right? Also if it’s not the version I want at the end of the updated then I select no, and go through the process again until I get the version I’m looking for? Because I have read that somewhere else online that people say you might have to do it up to 3 times for it to actually register the new software and switch over...but you have been a great help and I am very appreciative of yours/ anyone else’s feedback. Thanks!
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,340 Posts
So I have a 2015 challenger r/t scatpack with the 8.4 RA4 system sound group 2 9 speakers + 1 8” subwoofer in the rear deck. I recently tried updating to the newest Uconnect version via usb stick and it goes through all the update procedures fine. However at the end of this update it seems that it doesn’t actually update and still says “ update from 17.11.07 to 17.11.0743” yes/no”. Did it update and it is just abbreviated or did it not update? Anyone that has gone through this similar issue your advice would be of great assistance! Thank you!
The latest update for the RA4 is 17.43.01 which is the last version that supposedly unbricked sport mode across all trim levels.
 

·
Registered
Joined
·
5 Posts
So I have a 2015 challenger r/t scatpack with the 8.4 RA4 system sound group 2 9 speakers + 1 8” subwoofer in the rear deck. I recently tried updating to the newest Uconnect version via usb stick and it goes through all the update procedures fine. However at the end of this update it seems that it doesn’t actually update and still says “ update from 17.11.07 to 17.11.0743” yes/no”. Did it update and it is just abbreviated or did it not update? Anyone that has gone through this similar issue your advice would be of great assistance! Thank you!
The latest update for the RA4 is 17.43.01 which is the last version that supposedly unbricked sport mode across all trim levels.
I don’t know what you mean by unbricked. What was the issue regarding the sport mode that you say it was bricked? Unless I didn’t realize I thought my sport mode was working fine...but now I don’t know lol
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,340 Posts
I don’t know what you mean by unbricked. What was the issue regarding the sport mode that you say it was bricked? Unless I didn’t realize I thought my sport mode was working fine...but now I don’t know lol
Version 17.11.07 caused sport mode to stop working on a lot of folks rides. On my vehicle, when I pressed sport mode the flag would show but you would not get that kick at low speeds when enabled. 17.11.37 was the next update but only for manual trans vehicles. 17.43.01 was the fix for both auto and trans challengers. It apparently fixed everyone's sport mode because that thread hasn't come up in a long time. I am running it now with no issues.
 

·
Registered
Joined
·
6,007 Posts
what is the latest version for the 2015 without NAV?<<Never mind I looked it up>>>

BTW I don't think they can put Apple Car Play or Android audio on these older radios, probably not enough memory and not the right media hub in the console.
 
1 - 11 of 11 Posts
Top