Dodge Challenger Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Anyone have their usb port fail? I've had this car about 2 weeks and it worked fine until today. Now it won't recognize any of my zip 'flash' drives. (tried about 8) Don't know if it matters but it's a 2015.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
17,021 Posts
First thing I would try is pull the battery negative cable for 15 minutes or so, easiest "fix" if it works. A Guy
 

·
Premium Member
Joined
·
1,642 Posts
Anyone have their usb port fail? I've had this car about 2 weeks and it worked fine until today. Now it won't recognize any of my zip 'flash' drives. (tried about 8) Don't know if it matters but it's a 2015.
Hi artee345,

Sorry to hear about this! If you end up deciding to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Dodge Social Care Specialist
 

·
Registered
Joined
·
162 Posts
This literally just happened to me on Saturday... I read a few threads here and apparently this happens from time to time. Pull fuse 12 and 38 I think, in the trunk fuse panel. Beware, they are really a bit of a pain to get in there.

I pulled mine. Started up the car. Voilla! No issues. Brand new car to boot, but It was an easy fix.

Here is the thread I found regarding this... Page 2 last post.
http://www.challengertalk.com/forums/f188/17-rt-usb-not-working-586457/index2.html
 

·
Registered
Joined
·
2 Posts
same thing for mine

The samething keeps happening to mine. I plug the phone up to the USB and the 8.4 screen either freezes or resets. It happened more than one time in a 2 hour car ride a few days ago. The USB actually kills the Battery of the phone instead of charging it when using the GPS? Any reason why the Screen is so hot also?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
Do you mean pull out fuse 12 and 38 and then push them back in as some type of reset? Or pull and replace assuming they are blown? or (least likely) pull out and leave out?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
This literally just happened to me on Saturday... I read a few threads here and apparently this happens from time to time. Pull fuse 12 and 38 I think, in the trunk fuse panel. Beware, they are really a bit of a pain to get in there.

I pulled mine. Started up the car. Voilla! No issues. Brand new car to boot, but It was an easy fix.

Here is the thread I found regarding this... Page 2 last post.
http://www.challengertalk.com/forums/f188/17-rt-usb-not-working-586457/index2.html
Thanks for the advice Skeet. Pulled fuse 12 and 38, tried it, no go. Inspected fuses, both good, reinserted, tried it, no go again. Guess it's off to the dealer for me.
 

·
Premium Member
Joined
·
1,642 Posts
The samething keeps happening to mine. I plug the phone up to the USB and the 8.4 screen either freezes or resets. It happened more than one time in a 2 hour car ride a few days ago. The USB actually kills the Battery of the phone instead of charging it when using the GPS? Any reason why the Screen is so hot also?
Hello,

Sorry to hear about this! If you decide to make an appointment at your dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Dodge Social Care Specialist
 

·
Registered
Joined
·
97 Posts
What is the failure you experience? I have tried multiple flash drives with music on them and they fail. I can't remember the exact error message but all the drives work in my desktop and laptop. My wife gets the same error in her '13 Charger.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
What is the failure you experience? I have tried multiple flash drives with music on them and they fail. I can't remember the exact error message but all the drives work in my desktop and laptop. My wife gets the same error in her '13 Charger.
I never got a display code but the radio display did not recognize that there was a flash drive inserted. The solution was embarrassingly simple. Using a mirror, my son examined the USB port in the console. He found that the center (male) portion of the port was bent over, not allowing the drive to insert properly. He pushed it back to center and now it works fine. Surprisingly, the flash drive felt like it was perfectly seated at all times. I remember that it stopped working when I was blindly changing flash drives while driving on the expressway. I guess I pushed a bit too hard and bent the innards of the port. This is the first USB port I have ever experienced that can flex and bend. Probably not the solution to your problem, but this post may help someone, sometime.
 
1 - 12 of 12 Posts
Top