Dodge Challenger Forum banner
1 - 12 of 12 Posts

Registered
2016 Dodge Challenger
Joined
6 Posts
Discussion Starter · #1 · (Edited)
Has anyone received this error message? Uconnect 8.4 NAV Soundgroup II. 2016 Challenger V6 (I know, I know). I was hoping someone may have a fix or ideas, the car originally came with the tiny trash radio and I purchased a hellcat radio and swapped them out.

Any help/ideas would be appreciated!

Thought I should add the stereo works fine! The message just pops up when the car is started just gets annoying lmao, and I apologize I could only afford a V6馃ぃ bought the car with all the hard earned money I had saved at 17 as it was my dream car. Thanks.
Light Automotive design Car Steering part Vehicle
 

Registered
Joined
188 Posts
Not a thing wrong with having a V6 Challenger! They are all great cars, and the V6 would destroy most of the performance cars that were available when I was 17!! No apology needed, you be proud that you had the determination at that age to work hard and buy your dream car. That鈥檚 awesome!! Hope you get that radio issue worked out.
 

Super Moderator
2016 SXT Plus Blacktop
Joined
31,305 Posts
Welcome to Challengertalk ;) Is the rearview mirror light continuously illuminated red? Check all your connections


If the antenna connection is loose, if the antenna is bad (roof antenna), it will cause that message

A Guy
 
  • Like
Reactions: Skreet2x

Premium Member
Joined
3,364 Posts
Long story short, you have to go to the dealership to let them map the new unit to your VIN.
This is where I would put my money if I was betting.

The head units are married to the VIN of the car they came with. I wish you luck, and at least the radio part of it is working for you.
 
  • Like
Reactions: Skreet2x

Registered
Joined
1 Posts
Has anyone received this error message? Uconnect 8.4 NAV Soundgroup II. 2016 Challenger V6 (I know, I know). I was hoping someone may have a fix or ideas, the car originally came with the tiny trash radio and I purchased a hellcat radio and swapped them out.

Any help/ideas would be appreciated!

Thought I should add the stereo works fine! The message just pops up when the car is started just gets annoying lmao, and I apologize I could only afford a V6馃ぃ bought the car with all the hard earned money I had saved at 17 as it was my dream car. Thanks.
View attachment 1041709
My vehicle is currently having this problem also. How do I solve this problem? I have a 2016 Dodge Challenger SRT 392
 

Registered
Joined
373 Posts
Mine does this too. The Mirror was supposedly incorrect, so they installed a new one. It still does it. Now they said the radio isn't right for the car. I call BS. I think its more to do with I won't pay to connect to UConnect live service and the phone is no longer enabled.

On the upside, the car can't receive outside updates over the air, so is this a good theft deterent? Is my car invisible to electronic interference?

Wireless communication is voodoo! LOL
 

Registered
Joined
1,572 Posts
Wondering if the SOS or Assist buttons do anything after a certain time period. I don't know if the service is included for the first 3 years, 5 years, or for the lift of the vehicle. And is it suppose to be using the Sprint network on 3G? If so is that feature useless since there won't be 3G anymore?
 

Registered
2015 RT 5.7 M6
Joined
11,647 Posts
Same thing happened to my 2014 Ram,,, like A Guy said, check sharkfin antenna ,,,rain water tends to short them out after time,,,,,,,you can source a new antenna ,plug it in,and see if it resolves your issue,,,,here's one source-More Information for MOPAR 5064648AC
More like an open. When I was trying to disable 3G on my challenger I removed the antenna and got the same error. Had to install a resistor to get the rear view mirror light and message to go away.
 
1 - 12 of 12 Posts
Top